Hook 3.3 public BETA 2 then Beta 3 available for testing

Hook Version 3.3 public BETA 2 (4522; Integration v. 179) is now available for testing.

For more information and a link to the download please see the Hook 3.3 public Beta release notes page.

Hook 3.3 Public beta 1 was described in this prior forum topic.


Thank you to users who have made suggestions, reported issues, contribute to the forum, read the forum, and/or simply use Hook.

Is there a link to download v179? I can only find the download link for v178 in those links.

Sorry if this is a stupid question but since Hook started “living” in my dock there is a badge on it that doesn’t go away. I like having Hook in my dock :slight_smile: but the red badge is a distraction. Am I doing something wrong?

When I click the link here, it takes me to: “Hook Version 3.3 public BETA (4513; Integration v. 178)”


I have “Hook Version 3.3 public BETA (4513; Integration v. 180)” installed.

The badge disappeared after a restart of the computer so this report can be ignored.

It seems that the link gives v180. My bad. :sweat_smile:

Thank you for the notice. It seems we had saved/previewed but not actually published the update. Very sorry about that.
the Hook 3.3 public BETA – Hook page is now updated.
You may still get a more recent integration script number since we can release scripts on the integration server after the Hook.app dmg is built.

1 Like

I would appreciate it if you could create a global shortcut option for 「Copy Quote and Link」 :heart: :heart:

1 Like

I installed the update Version 3.3 Public Beta (4522; Integration v. 180). When I go to activate Hook after rebooting I got a license agreement window (or at least I think it is) and a dmg image ends up on my desktop. This happens twice, after that, the application works fine. Any ideas?

If you previously launched Hook from a DMG, rather than the app folder, then macOS might remount the DMG. please discard old Hook DMGs in that case (YOu can keep a compressed version of it if you like.)

Thanks for the reply. Closed the app and opened directly from Hook.app in the application folder. I guess it was launching of the older dmg after reboot as I have it launch automatically. Works now. Appreciate your prompt reply.

1 Like

FYI. Hook 3.3 public BETA 3 – Hook is now available for testing. The release notes show what has changed in Beta 3 specifically (and 2).

Release notes:

DEVONagent Pro by DEVONthink is now supported.

DEVONthink and DEVONagent are each products of DEVONtechnologies, not “by DEVONthink”.

1 Like

We would love to provide testing assistance through TestFlight.

1 Like

Hook 3.3 public BETA 4 available for testing as described in this forum topic, so I’m closing the current topic, to keep the discussion focused on the the latest beta.