Zotero 7 compatibility

Hi Team Hookmark,
Zotero 7 is now in beta 26 and will be released later this year. As of now, Hookmark 5.1.3 cannot find any linkable items in Zotero v7beta. It would be great if Hookmark was able to detect files in Zotero 7 as it is with v5 and v6. Thanks for looking into it, Marc.

Thank you for reporting this issue, @kithairon .

I just tried it and saw the same problem. It turns out that current Zotxt is not compatible with Zotero 7 beta.

Hookmark relies Zotxt to get Zotero link. It seems another Zotero extension Better Bibtext for Zotero is also not compatible with Zotero 7 beta.

We will contact the author of Zotxt for this issue. If anyone in Zotero community could also reach out to the author, that would be greatly appreciated.

Thank you

Ok - this makes sense. Re the updates for Zotxt and BetterBibtex: the news is good. Both developers have indicated that updates to their respective plugins with Zotero 7 compatibility are in the making – See here for zotxt and here for Better Bibtex.

1 Like

Thank you for the great news!

1 Like

Better Bibtex is compatible but you need to run beta build that are added to cerain github issue onle (they don’t appear in releases tab)
They are added here Work on zotero 7 support is underway · Issue #2522 · retorquere/zotero-better-bibtex · GitHub

Zotero has QuickCopy with Cmd+Shift+C, It works within Zorero 7
If you install Zotero Markdown translator, you could copy it as markdown link, the result looks like that:

[Satrio. 2020. *Jensen Inequality*](zotero://select/items/_UNHPGY8R)

This is working in Zotero 6 and Zotero 7 as well.

Could Hook just hook to this QuickCopy? shorrtcut?
Maybe someone could write another translator to get RTF or this could be converted within Hook if someone want to use it in a rich form (Mindnode and OmniOutliner doesnt like Markdown for example)

Could you please update your Hookmark script and see if it works with Zotero 7? The script version is 284.

Thank you

1 Like

Thanks! It works for me with the latest Zotero beta 7 :slight_smile: !

For people who want to reproduce my setup you need to install and set to quick copy (Settings> Export) shortcut to one of these translators GitHub - erazlogo/zotero-markdown-translators: Two Zotero translators that help you transfer metadata from Zotero to an Obsidian note, or any markdown note.
If you set quick copy to other option (like bibliographic formatting) it will not work

BTW Offtopic but Zotero just testing epub reader i webpages annotation Available for beta testing: Updated reader with EPUB/snapshot support and new annotation types - Zotero Forums

1 Like

Edit: Both pasting rich text in Hookmark with Cmd + C and markdown with Cmd + M work great !

Happy to confirm that Hookmark script 284 works with the latest Zotero 7 Beta (.beta.32+5e27a7501) with erazlogo’s translators set in Zotero’s export settings for Quickcopy. Successfully pasted working links with Cmd+C and Cmd+M. – Thanks for the good work!

Off topic: Delighted to drag extracted annotations from PDFs in Zotero with working backlinks to Obsidian! And the new reader features with EPUB support looks great!

With the latest beta (7.0.0-beta.33+437e2bd92) hooking to Zotero Item is possible also when we have open PDF in Zotero PDF browser, not only from the main Zotero windows (I was testing it recently and it was not possible until now, I think), its great news!

@echej: Well spotted – thanks for the hint. Tried this some time ago and it didn’t work. Great to know it does work now!

We also have deep links to PDF highlights and annotations marked in Zotero’s PDF viewer. By simply dragging and dropping the annotation from Zot-Viewer to say Obsidian, and presumably to other note-taking apps, I get two links: one to the Zotero item, one to the actual annotation showing up in Zotero’s viewer. All this happens outside of Hookmark. I wonder what it would take to get this functionality – i.e. deep linking to PDFs and ePubs in Zotero’s viewer – into Hookmark?

Currently, we have Hookmark support for linking to the actual item – which is great. But deep-links are so fantastic – I’m using this with Hookmark in PDFPenPro/Nitro PDF and would love to see the same functionality in Hookmark and Zotero’s Viewer.

1 Like


I followed the workaround proposed here (using QuickCopy and the Markdown exporter) but I can’t get it working. I’m using Zotero 7.0.0-beta.38+b79e0b3d7 and Hookmark 5.1.3 (5475) (scripts version 286).

Anyone else having troubles with that?

Edit: Also tried with Hookmark 6 beta 2 (which says it features Zotero 7 support) and it does not work either :frowning:

Welcome to the Hookmark Forum , @adry26 . thanks for asking.

What specific compatibility issue are you seeing? Copy Link and Copy As Markdown Link at the file-level not working?

I installed Releases · egh/zotxt, relaunched Zotero, invoked Hookmark {Version 6.0 beta (5751; Integration v. 286)}. It hung (don’t know why, and cannot reproduce, but am investigating). I relaunched Hookmark. Copy As Markdown Link, Copy Link works at the resource level. Zotero opens the links fine.

Oh, I was using zotero 6.0.26 . Because Zotero 7 is still in beta, we’ll have a look at it when our zotero integration prime returns from vacation in early Sept… Others having an issue with zotero 7 beta?

I am using only Markdown Item URI translator form github as Item Format in Quick Copy (zotxt doesnt support Z7 yet I think), and linking works fine in Zotero 7

@adry26 does the quick copy from Zotero works for you with Markdown translator when you use it? Leaving aside Hookmark


Copy Link and Copy As Markdown Link work with the setup I already mentioned. It works when I use the shortcut aswell. It even works when I manually click the Hookmark icon on the status bar. But it does not work when I invoke it “launching” the app (I have a Raycast shortcut that, when I type “hk”, it invokes Hookmark).

As a workaround, I can manually click on the status bar Hookmark icon for now…


The Markdown Item URI translator works just fine. I can Ctrl+Shift+C and it invokes the QuickCopy action on Zotero 7. The problem is that the script that should be triggering this exact shortcut on the Hookmark side is not working. It is not triggering this QuickCopy action…

I have the same script version; I dont have any idea where the problem can come
Do you have in Hookmark “Item not found” or other error?

Maybe you could paste manually in Zotero 7 “Get adress”

-- This script assumes zotero-markdown-translator is installed from https://github.com/silentdot/zotero-markdown-translator/tree/main and keyboard shortcut for markdown Link is shift+command+C. The script can be changed to use a different keyboard shortcut.

set the clipboard to ""
delay 0.1

tell application "System Events" to tell process id "org.zotero.zotero-beta"
	keystroke "c" using {shift down, command down}
	delay 0.1
	repeat 20 times -- poll clipboard for ~2.5 seconds. Sometimes set x to the clipboard throws exception
			set markdownLink to the clipboard
			if markdownLink is not equal to "" then
				exit repeat
			end if
		end try
		delay 0.1
	end repeat
end tell
return markdownLink

I have the same script, which of the following shortcuts is triggering this script?