Support setting default PDF viewer for opening Deep Links

Currently, PDF tools like PDFpen and Skim support Deep Linking to specific text in a PDF document. On the hand, other PDF tools like PDF Expert may be the preferred tool for reading PDF documents. However, tools like PDF Expert does not support Deep Linking yet. Therefore, is it possible to support setting a default PDF tool for the purpose of Deep Linking? Then the workflow may be as follows:

  • One reads PDF documents in a preferred tool like PDF Expert and annotate and take notes there.
  • If one wants to Deep Link to specific text in the PDF document, one uses another PDF tool like Skim for Deep Linking purpose.
  • After reading, if one wants to navigate to a specific Deep Link, one may click the link, and it would go to the specific text in the set default PDF viewer for Deep Linking, e.g. Skim.

The main reason for not setting a default PDF viewer that supports Deep Linking system-wide is that the reading experience of such a PDF tool may not be desired. For this, it would be great if one can set a default PDF tool for Deep Linking purpose. There can be the following options for this purpose:

  • One can set the system-default PDF tool for opening Deep Links.
  • Instead, one can choose to set a PDF tool that is not system-default for opening Deep Links.
1 Like

My skim crashes frequently when I jump to a pdf using deep linking. Don’t know why.

thank you and we agree it would be helpful particularly in this case. I’m sorry we haven’t gotten to it yet.

1 Like

Welcome to the Hook Productivity Forum , @ghs2015. could you please let us know your version of Skim , macOS and Hook?
Does this happen with any PDF? Any deep link?
What language is your macOS set to?
can you paste an example deep link?
can you try with a PDF that is in the home folder or Documents folder to see if it makes a difference?

Hook simply calls some AppleScript, so it sounds like Skim is having difficulty with the AppleScript call for some reason.

Thank you very much for the reply.
My Skim version is Version 1.6.5 (135).
OS version: Monterey 12.0 Beta (21A5534d)
Hook version: Version 3.2.1 (4468; Integration v. 182)
This only happens with Skim. And I followed the instructions to setting skim as the default pdf viewer.
OS language is US English.
When I tried pdf under the home directory, it worked as before. The previous location of the same file is at an external drive, which seems to be the reason.

Is there any way to fix this? Thank you!

This may address that issue: Hook 3.3 public BETA 5 – Hook. (not hanging, but URL resolution on the external drive.)

Thanks for the solution. I will move the pdf back to the external drive. :joy: