[SOLVED] No linkable item in ungoogled Chromium

Hook doesn’t seem to work with Chromium 8.0.4324.192 (Official Build, ungoogled-chromium) (x86_64)

Intel Mac - MacOs Catalina 10.15.7

Any help? Don’t tell me that I have to change browser :cry:

Screenshot 2021-06-08 at 22.35.23

Welcome to the Hook Productivity Forum , @splitpersonality, and thanks for asking.

that app’s not supported yet, but if it is similar enough to Chrome you would be able to copy Hook’s Chrome script and paste it into a new Chromium bundle: Scripts Tab – Hook , which might do to the trick.

Sounds promising, where can I find and how can I apply the script? The link you pasted looks great, but it seems like a broad spectrum introduction to what scripts can do, rather than something actionable to solve this. Please correct me if I am wrong

Hook’s Get Address for Google Chrome script could be adapted as follows:

tell application "Chromium" to return URL of active tab of front window

HOWEVER I don’t know if it would work with Chromium. It depends on its AppleScript dictionary (if any). Or perhaps it has some x-callback-url or other API? I haven’t looked yet.

  1. Hook > Preferences > Scripts
  2. press “+” button at bottom left. Choose Chromium from the dialog box. close the dialog box.
  3. select the “Get Address” tab.
  4. paste a script in there
  5. hit the save button (bottom right)

repeat for the address script and tab:

tell application “Chromium” to return title of active tab of front window

If you’re not familiar with script editing, it might not be worth trying out more than the above.

what’s the URL of the official Chromium project?

1 Like

Ha! It worked, thanks so much.

I came to the same solution by scanning the forum and following this guide: Hook with Brave Browser

Thanks for laying down the steps

1 Like