Quirks with Invoking Hook?

#1

Hey, Gang.

I’m absolutely loving Hook so far and I need some help with something.

Sometimes when I invoke Hook with the keyboard shortcut, keystrokes produce that “error bump” sound or whatever it’s called and, of course, nothing happens. If I press tab twice, I am then able to navigate the list with the arrow keys to select whatever command using the “enter” key.

This is not consistent, however, and sometimes I get no error bump sound and everything works as expected. I can imagine the problem here is between my keyboard and chair. Can someone tell me what I’m doing wrong?

Other than that, I can hardly wait to spend money on this app. This thing is life-changing.

Quinn

1 Like
Build 2305 of Hook Version 1.0-beta is now available
#2

When I hear the “error bump” (I call it the “bonk” sound – Apple calls it “basso”) it’s usually because the keys pressed or shortcut used interferes with another shortcut or command that the app I’m using expects to receive. I.e., a conflict.

What apps does this occur with for you?

#3

I’ve seen something like this occasionally when I first launch Hook. Others here haven’t been able to reproduce it yet. Then it goes away. Is this when you see it too?

#4

It happens reliably in Bear.

With a note selected in the notes pane, I invoke the Hook window with keyboard shortcut (⇧⌃⌥⌘ - space for me).

With the Hook window visible, any keystroke triggers the “basso” sound (thanks, quorm for the info), except for tab. One tab stroke moves focus to and highlights the gear icon and a press of the space bar will activate the gear menu. A second tab stroke moves focus to the command list (or whatever the official designation is for the main part of the window) and everything seems to work as expected from there.

Quite often, though not always, the invoking of the Hook window in this manner triggers that whooshing electronic trill. I don’t know what that one’s called, either. But I’m sure everyone’s heard it at some point.

That’s as far as I’ve had a chance to investigate it so far. Anything else I should try?

#5

Does pressing Space with a note selected do anything in Bear?

#6

Not as far as I can tell.

#7

Manually clicking in the Hook widow should allow you to then use the keyboard. Of course, we need this not to require using the mouse/trackpad.

#8

Have you tried setting up a new user account, just installing Hook and Bear and see if it still happens.

I’m thinking it could be an interference between them and another app that captures keystrokes such as TextExpander or Keyboard Maestro.

(I don’t have Bear so unable to check if it’s a universal issue)

#9

It looks like in context of Bear, for some users , sometimes the gear menu has “focus”. That explains why hitting the tab key solves the problem. We’re investigating this.

#10

Cool. I will keep that in mind.

Thanks for looking into that.

#11

This problem is now solved with Build 2305 released a few minutes ago.