Problem changing to Setapp version of Hookmark

Continuing the discussion from Switching over to SetApp version without losing my Hooks:

I had an old version of Hook which I’d not used for some considerable time - probable version 3.6.1 or thereabouts - and I wanted to change over to the Setapp version. I followed the instructions, saving screenshots of the preference tabs, compressed com.cogiapps.hook/ and then changed that to com.cogiapps.hook-setapp/. This didn’t seem to work and I thought that since Hook had been renamed Hookmark I should change that to com.cogiapps.hookmark-setapp. This seems to produce better results but I still couldn’t find any of my links.

I had been in the habit of producing notes with the main title of my link and then appending to the note the links that had been attached to the main link so I have all the links there so I could use this to link all my items together but what has happened to all my previous links?

It should be com.cogsciapps.hook-setapp.

Could you please be more specific when you say it is not working? Do you mean you can’t start Hookmark, or the links are not showing in Hookmark window? If you can post error messages or screenshots, that would be helpful.

Thank you

Sorry, I did mean com.cogsciapps.hook-setapp. I see I now have both hook-setapp and hookmark-setapp files in my Library - see the screenshot.

I can open Hookmark OK but no links are showing if I start a search. I did try to produce a link from the ones I’d had showing in my Notes but all I’ve got is a list of bookmarks which show as ‘Recent’ when I open up Hookmark. I’ve not been able to produce screenshots of these results as the Hookmark screen disappears when I use my screenshot app.

Thank you for the info and sorry about this problem.

Could you please remove all or you downloaded from, make sure you only have Hookmark from Setapp? You can check Hookmark about window and see if it is from Setapp. Please check menubar and make sure there is only one instance of Hookmark is running.

To make a screenshot, you can use shift+control+command+4, then select the area to copy.

Thank you

Welcome to the Hookmark Forum , @RobbieSnr.

Could you also please send us the console output:

Open /Applications/Utilities/Console

please type “Hook” in the search field. then try to invoke Hookmark where you would normally try (e.g., in Finder) ; then copy and paste the results into a file. Compress the file from Finder, and email it to us at, referencing this topic: Problem changing to Setapp version of Hookmark

thank, you.

@bchend Many thanks for the reply. I have checked and I don’t have a running but I do have a one. I’ve checked and it is shown as the Setapp one.

Re the screenshot I am using CleanShot X for my screen captures where shift+command+4 is the area copy shortcut. Unfortunately I used shift+command +5 which brings up the All-in-One box to allow different types of screen copying and this is what killed the Hookmark screen.

I’m now following @LucB’s suggestions.

@LucB many thanks for the reply. I’m not sure if I’ve produced the log you want. Here’s what I’ve done.

I opened up that Console then with the name of my iMac device highlighted I entered Hook in the search field and pressed Return, and then clicked the start button. Next I went to the Setapp folder in Finder and clicked on Hookmark. There was a lot of output in the Console window (241 messages). I copied all this output and saved it in a TextEdit file, compressed it and have sent it off to you by email as requested.

I’m keeping my fingers crossed!

1 Like

@RobbieSnr. While we are investigating. please try the following steps:

  1. Shutdown Hookmark.
  2. Under com.cogsciapps.hookmark-setapp folder, remove file 1.1 and 1.2.
  3. Restart Hookmark.

@bshi I’ve done that, removed these two files and started up Hookmark again. I’m afraid the result is the same,

1 Like

It seems the database in com.cogsciapps.hook-setapp is corrupted. I just noticed that the size of hook.sqlite is so small. It could be empty.
Could you please check the size of hook.sqlite in your com.cogsciapps.hook folder? If the size is much bigger, then you can copy that database file to com.cogsciapps.hook-setapp folder and restart Hookmark .

Also , do you back up your mac periodically?

Thank you and sorry for this issue

@bchend Yes the hook.sqlite database in the com.cogsciapps.hook-setapp is pretty small at 188KB while the one in com.cogsciapps.hook is 983MB. I have copied over the larger sqlite database to the hook-setapp folfder and started up Hookmark.

This does seem to have solved my problem. I can go to one of the Notes I’ve stored in my Hook Notes folder and then invoke Hookmark which now shows all the files I’ve linked to that Note. Incidentally I see I have 192 bookmarks - it does seem quite a lot. I have quite a bit of work to do to become familiar with Bookmark again!

Regarding backups I’m just using Time Machine to back up my Mac.

Many thanks for all the help I’ve been given to sort out this problem

Thank you for letting us know! I am glad the problem is solved.

This is very good.

Thank you