No linkable item found in Calendar in Ventura [fixed in Integration version 249]

Is known to be working with Hookmark?

I know in the past, I needed to keep the event selected for about 5 seconds or so before Hookmark could pick it up, but recently I cannot get Hookmark to see my events at all.

P.S. When I run the Get Address script, by itself, in Script Editor, it errors out:
error “Parse error near line 2: no such table: zcalendaritem” number 1

It’s currently working for me, with the usual delay needed.

Calendar v11.0
Hookmark script v240

AppleScript can be finicky in Calendar if you have a panel open, or multiple windows. Calendar can get confused about focus. Have you tried closing windows and relaunching Calendar?

macOS version?

Ventura 13.1
Hookmark Version 5.0 beta (5270; Integration v. 246)

I’ve quit both Calendar and Hookmark multiple times, restarted, but still get the no linkable item found message.

I have the same problem. Calendar 11.0, Hookmark 4.0 (haven’t tried the beta yet), scripts bundle v248. I noticed that Calendar is not showing up in System Settings > Privacy & Security > Automation > Hookmark. It’s just not there at all, so I can’t uncheck and recheck it. And of course there’s no way to manually add apps to that list (that I know of). Seems Hookmark just hasn’t been able to trigger the ask for that permission or something.

Thank you for reporting this issue!

We have fixed the issue(script version 249). Please use the Check for App Updates and Update Scripts … function in Hookmark’s gear menu, or in its Hook > Preferences > Update tab .

Please let us know if there is any problem.

Thank you

Progress! But alas, not enough to resolve the issue. With script version 249, I got the permissions alert asking me if I want to allow Hookmark to control Calendar. I said yes, but Hookmark still reports it is unable to find any linkable items in Calendar. System Settings still doesn’t show Calendar in the Hookmark Automation permissions either. :frowning:

I restarted Hookmark and Calendar and also rebooted my Mac. Still no dice.

What’s your macOS version? My macOS version is 13.1.

Have you try this:

1.1 Your accessibility permission database is corrupted

The macOS accessibility permissions database can get confused. In that case you might see strange behavior like not being able to disable or enable permissions for an app. In that case, you may reset Accessibility for Hookmark as follows:

  1. tccutil reset Accessibility com.cogsciapps.hook
  2. Reboot your Mac.

For example: Accessibility problem – Discussion & Help – Hookmark Forum.

Ah, that might be the problem. I’m on 13.2 beta (which I need to be on for work). I just tried on another machine running 12.6.1 and it worked fine.

I’ll try resetting accessibility and report back. If that doesn’t work, I’ll see if I can get another machine set up with 13.1 on it and try it there.

Resetting accessibility fixed it! Funny, I didn’t think to try that since it seemed so Calendar specific. After resetting, I didn’t get another permissions prompt for Calendar. I just got the general accessibility prompt. But once it was reenabled, I could copy links from Calendar.


I may have spoken too soon. Resetting Accessibility did fix it. But after copying a few links to meetings, it stopped working again. :frowning_face:

we’ve released a new fix for Ventura on Hookmark’s Integration server. Version 250.

It’s actually working better than it did before. There is no longer any self-imposed delay needed when selecting an event. I select an event, hit my shortcut, and I see the event in Hookmark’s window.

Here’s how I made it work.

  1. Update Hookmark
  2. Reset the Accessibility permissions, and the re-enable them.:
  3. tccutil reset Accessibility com.cogsciapps.hook
  4. Quit calendar
1 Like