Accessibility problem

I restarted my Mac and it is now asking me permission to authorize Hook. The problem is 2-fold. First the is already checked. I realize the instructions say, “If checked, then click and uncheck … etc.” However, I can’t uncheck the box! So I’m completely stuck. See below. Any solution for this?

that’s strange. Looks like a macOS issue with your user account. Does it affect HoudahSpot as well? What macOS version do you have? Have you tried logging out and logging back in?

This does not impact HoudahSpot. I have macOS 11.3. Yes, I have tried logging out and back in. Restarting also. No luck.

… in fact over time this seems to be getting worse. At one point I got the message about Hook (but also some other things) and I could unclick, then click. Now I can no longer unclick. No idea at all how to fix.

I recommend trying this from command line:

tccutil reset Accessibility com.cogsciapps.hook

that should do what it says.

@LucB The good news is using that command allows me to uncheck and check the checkbox. One step forward! The bad news is it doesn’t seem to “register” or “stick”. Each subsequent time I try to open Hook I get the message below.

I should say the checked box sticks just fine, but something does not recognize that Hook should now be safe to open.

This looks like a macOS Accessibility bug perhaps with one of macOS’s databases for your account having an issue. Compare TIP: Resolving Big Sur Accessibility, Security, and Other Issues - Tips & Tutorials - Keyboard Maestro Discourse and TIP: Resolving Catalina/Mojave Accessibility/Security Permissions Issues - Tips & Tutorials - Keyboard Maestro Discourse .

I forgot to suggest you reboot after doing the tccutil reset Accessibility reset. You might need to redo the reset and immediately reboot.
(as an aside, this is an example of why many developers, ourselves included, have been urging Apple to take it slow and address their bug backlog rather than introduce new features. WWDC 2021 didn’t announce major underlying macOS changes, which might actually be good in this respect; but it’s hard to tell how much bug fixing happened.)

@LucB Thanks so much! Wow, pretty amazing that this is a known bug that hasn’t been fixed for awhile. Ugh!

At any rate your suggestion of using the command, the immediate restart, did the trick! Thank so much. I really appreciate your patience and help.

1 Like