Kindle deep linking in Hookmark integration v. 261 adds support for deep linking

Integration v. 261 is now available. We’ve added integration with the Mac Kindle app. Copy Link not only delivers a link but it delivers a deep link. The book needs to be open (not merely selected in the library).

You will need to reboot Hookmark after you update your scripts. (This is almost never required but Kindle integration needed a special twist).

We’ve added several integrations updates recently . They are not all announced on the forum yet. (Sorry!) Those of you who subscribe to our newsletter are aware of latest updates. (We even pre-announced Kindle integration there.)

Thanks to @bchend who has been handling customer support for me recently as I have been juggling some pretty big balls. We will be making some happy announcements soon.

I’ve also been thoroughly enjoying using Hookmark for a massive co-authored theoretical paper on sleep onset and insomnolence (> 50 pages; extremely unusual). It discusses cognitive, affective and general psychology relevant to the topic (much of which outside our work has never applied to this topic, plus relevant sleep onset and insomnolence literature directly, our somnolent information processing theory postulates, the cognitive shuffle, and wearable applications.

I feel a bit like how Immanuel Kant must have felt after delivering his Critique of Pure Reason, as in: “sorry it took so long, dear readers; and sorry it’s so long. I hope you like reading it as much as I enjoyed writing it.”

I mention this because Hookmark has been extremely useful in writing this paper. The number of use cases is staggering, but not so surprising when you think about how general are the concepts behind Hookmark (linking / contextual computing, to use @MacSparky 's apt term).

More on all this later.

This doesn’t work for me. Not sure if I am doing something wrong.

I copy the link when I am in Kindle and I get back something like this:


But when I click that link to try and use it, it will open the book in Kindle but it will not go to that location.

Should I be doing something different?

Thanks in advance.

Thanks, @arthurwerry . In my rush and enthusiasm last night I forgot to provide additional caveats:

  • if the book is open Amazon Kindle app for Mac will ignore the deep part of its URL
  • this is a first pass at the integration so
  1. we have not done the localization yet. Copy Link will only work in English for now. We’ll localize the integration. (per the updated apps page).
  2. there may be other issues. In fact, we will release a fix later today, software integration v. number 262.
  • as noted:

We’ll soon publish a Using Hookmark with Kindle app page. For now, this topic is the reference.

Thank you! I appreciate your clarification.

1 Like

Integration v. 263 is now available.

Sometimes it does not take you to the exact place, off by 1 page. we are looking into that.

Was this integration pulled? Kindle linking doesn’t work at all, and I don’t see the script in Preferences.

What’s the script version you have, @Skeuo108 ? You can find it in Hookmark about dialog.

If the script version is < 263, please go to Hookmark preferences window->Update to get the latest script and restart Hookmark.

If you have the latest script, could you please send us a screenshot which has the kindle page and Hookmark window?

Thank you

It shows no linkable content. Where is the ‘script’ and how do I add the script and where do I add it?

What’s the script version you have, @yashodhankhare ? You can find it in Hookmark about dialog.

If the script version is < 263, please go to Hookmark preferences window->Update to get the latest script and restart Hookmark.

If you have the latest script, could you please send us a screenshot which has the whole kindle page and Hookmark window?

Thank you

I have 267, and I don’t even see a script listed for Kindle. I’ve updated several times, and rebooted both Hookmark and my computer more than a few times.

The behavior is this: I can Hook to New or Copy Link anywhere in book A…and the link names (when pasted, say, in Notes) reflect the title of Book A, as well as the relative deep-link position. But clicking on the links and following them always goes to book B (the book that happened to be open the first time I tried to Hook something).

I moved to other books and created links, all with the same effect — the links tracked back to a single book B (Moonwalking with Einstein by Joshua Foer, btw).

I just decided to completely delete Hookmark and all support files (it took a while!), and do a clean install. I wanted to rethink my hooks anyway. So we’ll give it another try. BUT - there is still no Kindle script in my Preferences script list. Nor anything under Amazon. Does it have a different name?

Could you please post the markdown links from those books here?

Thank you

Sure. As I look at them, it seems like it is capturing locations, but the book ID stays the same?

Here’s are the markdown links - see below. Also - can you just post the Kindle scripts here so I can add them? Unless they are built-ins and invisible to the user…because again, I have no application-specific script for the Mac Kindle app.

Arbiter of Worlds: A Primer for Gamemasters

Algorithms to Live By

Also FYI:
Mac Studio
Ventura OS, 13.2.1
Hookmark 5.0, 5317, Int. v267
All available systems permissions granted

(The screenshot version, as Markdown will be Markdown)

Thank you! I can see the problem. We will take a look.

Could you please let us know you macOS and your Kindle version?

Ventura 13.2.1

Kindle: Version: 1.40.0 (65466) Last Updated: 3/10/2023 12:39 AM

And thank you for being on top of this! Deep-linking Kindle books is a total game-changer for me, and for a whole lot of folks, I think.

You are welcome! Thank you for all the information!

Sorry I haven’t been able to reproduce the issue.

Have you tried reinstalling Kindle? If not, could you please give it a try?

Does Hookmark return all kindle links with asin=B004H4XI50? Will you be able to get a different asin number?

Thank you

the integration is English only at the moment. is macOS set to English?

Yes, only English.

I did just reinstall Kindle yesterday, though I did not do a thorough uninstall with deletion of Library files, etc. That would kill all my downloaded books, of course…

But I can always get them back, if you think an “erase all traces” uninstall might matter. I did exactly that with Hookmark itself last night.

Again, I wanted to be clear – am I supposed to see a Kindle script in Preferences? Because I’ve never had one.

It looks like every book returns the same asin: