Invoking a Roam page as main link for Hook bundle

Hi, I started using Hook and I think is is great! But I have Found a problem now that I am using Roam:
I am trying to use a Roam page the anchor of a bundle, for instance “house paperwork” , and then linking several documents in finder to the link.
This seem to work ok with my first bundle,
But when I add a second bundle for instance : “car sale papers” and build a second bundle, Hook treats the Roam page as if there were only one: the first one. I cannot add more Roam web pages as Hook always take the first one as the only one. Any idea what is going on here? @Conaw? I am signing in into Roam with my email.
Thanks

Welcome to the Hook Productivity Forum, @LuisSahagun .

Does the following recent discussion shed light on your query:
Invoking a Hook link in the context of roamresearch website - Discussion & Help - Hook Productivity Forum?

As long at the current page has a unique URI (the address shown in the web browser’s address bar), Hook’s “Copy Link” and Copy Markdown Link should work. Have you checked whether the address in the browser is sufficiently specific? You can do that by copying it (in the web browser, not even using Hook) and pasting it into a different (web browser) window’s address bar.

Hi Luc,
That thread did no help.
In fact I tried copying and pasting roam’s URL and worked fine between 3 browsers - all pointed to the right page… I tried with different pages and the 3 browsers worked fine.

It is a weird behaviour, even when I am not building the bundles, just invoking Hook to see which files belong to that reference I still get the very first Bundle in Hook attached from Roam.
I can share some screenshots if you think that would help.

I tried something new:
I openend the Roam page, then I invoked Hook which showed me the usual wrong links (the very first ones created ever from Roam), then I selected create a hook file.
Then I opened the hook file and it opened the right Roam page…
Does this helps?

If i do the same the same from Notion it works great!

am trying to use a Roam page the anchor of a bundle, for instance “house paperwork”

What’s a Roam bundle? Your title and posts refer to a “hook bundle”. There’s no concept of bundle in Hook. We occasionally refer to a “bundle of scripts”, but I don’t think that’s what you’re talking about. Roam is accessed via a web browser, so there’s no bundle of scripts specifically for Roam.

please do.

I am sorry, I don`t know how to call it, for me a Bundle is a set of links created in Hook based on a Anchor file, URL, etc…

This a case with Notion that works Great, when I press Shift-Commd-spce this I what I get from Hook

this is the first set of links (or however is should be called) using roam. Note that the URLs is unique. This works fine when I invoke Hook.

When I invoke another URL from roam (you can see it is different) I get the same set… even when I made a different one specifically for this URL.

Again, when I invoke Hook from another URL that has a set of links in Hook, I am still getting the same first set of links…

Hi @LucB, have you had a chance to look at it? thanks in advance

Sorry for the delay. I have reproduced this issue. Looks to me like the # in the URL may be throwing Hook off, but I can’t yet confirm that is the cause. In my case, one of the linked files also has a problematic URI. We will look at it. Sorry for the inconvenience.

Looks to me like the # in the URL may be throwing Hook off

Yes, this is the case, Hook ignores URL fragments, which usually means treating URLs like https://en.wikipedia.org/wiki/Dog#Behavior as equivalent to https://en.wikipedia.org/wiki/Dog#As_pets, because those URLs are two different spots on the same page.

Roam uses # in it’s URLs but not as fragments to denote page anchors, so Hook is misidentifying different URLs as being the same page.

We’ll look into the issue and hopefully have some kind of solution for you soon

I had forgotten that I had previously answered this issue here ! There, I noted that

at the time, Roamresearch told me over email that they would fix this issue.

It would be better for us not to update Hook to deal with non-RFC compliant websites. Customer may wish to ask Roam for status/ETA about when they will change their construction of URLs.

Hook could in the future provide an advanced preference to deal with websites that treat “#” differently (possible involving a service that lists such websites), but I’d rather postpone that.

Got it, I will open a ticket with Roam. thanks