Hook Version 3.6 (4781, 219) is available: Hooked status, Updated Agenda support, and more

In advanced of WWDC 2022 : Hook Version 3.6 (4781; Integration v. 219) is now available for download from its release notes page.

New: Hooked status in menu bar icon; updated support for Agenda; and more. See release notes page for more information.

In-app update is coming soon.

Gratitude

Thank you to everyone who tried out Hook 3.6, and any feedback shared regarding Hook.

1 Like

Hook 3.6 is now also available as an in-app update. Enjoy!

By the way, new feature, “Hooked status in menu bar icon”, is currently off by default. You can use Hook’s General preferences or command line to turn it on. Command line enables you to to set the polling interval, per the “Hooked” indicator in menu bar icon – Hook page.

The instructions for the CLI defaults command are…vague. All of the commands you offer in the linked page fail if copy-and-pasted as is. It took some digging around to discover that the complete command syntax for changing the hook display polling interval to 1 second was this:

defaults write com.cogsciapps.hook menubar.icon.status.interval 1

I strongly encourage you to update the release notes and the “indicator in the menu bar” page with complete commands, instead of fragments.

Though perhaps it’s a matter for another thread, are there reasons for the 3-second polling interval? Is there an anticipated affect on system resources if the script checks for hooks more frequently?

In addition to the 3 documented hooked status items in the menu bar, I am seeing a fourth - a black icon with a diminuative “7” or is it a “?” in the middle of the icon, my old eyes can’t tell. I’m seeing it when I copy a webpage link, and then to a “copy hooked link” (I think) while in Craft.

Thanks for the feedback, @lutefish. We’ve updated the “Hooked” indicator in menu bar icon – Hook and Advanced, Command-line Preferences – Hook pages.

Since we cannot test on all possible systems, we provided a user-configurable parameter. In our beta tests, where the feature was on by default, we received no negative feedback regarding the 2s default.

There’s a fourth state that can be shown after Hook to Copied Link or drag and drop on menu bar icon. It indicates that the two resources (the two links) have successfully been hooked together. That state is only briefly shown as it reflects an event.

Ugh … this new version is a bit of a PITA. I’m not seeing the Hooked status in menu bar. Yes, it has been turned on in prefs. … though that is the least of the problems.

Now it seems every app I open wants permission or “access to control” the specific app. Not a problem in and of itself … just mildly irritating. The problem on both of my computers is clicking on either “don’t ask” or “okay” simply doesn’t work for about 5 minutes. On my laptop that dialog box takes up a lot of screen space. Now that’s a problem! (Doesn’t matter which button I push … neither is active for awhile. They look active, but aren’t functional.) This is getting very tiring.

Restarting the computer doesn’t help. On both machines I’m using Monterey 12.4

The dialog box should look like this, the wording of which is different:

If not, can you please upload a screenshot or send it?

the dialog box is actually from macOS, which is responsible for sizing and dismissing it. So it’s strange that it’s big and not going away.

I would recommend reverting to Hook 3.5 if the issue persists.

@LucB Please see screenshot below. I suppose “big” is in the eye of the beholder. But on my laptop the notice is big enough to make it tricky to work freely within an app … something important gets covered up.

It also seems to ask for permission from “apps” that it never asked before. See below:

I have no idea why it takes so long to go away when clicked. Some apps are quicker than others … but there’s always a wait. Essentially it’s like starting up an app and it taking 3-5 minutes before you can use it. The good news is I only need to do this once for each app, but it’s a bit of a surprise time investment in the beginning.

thank you for the extra information.

what you showed in the screenshot is the dialog box we expected. I don’t know why it would take 3-5 minutes for the dialog to go away. That would be a macOS issue. We’ll research it.

The point of this new feature is that users need not manually invoke Hook in order to tell whether the current item has been hooked to something. Every time you switch to an app, Hook tries to see if it’s current item is hooked. macOS needs to request permission for every app that you bring to the foreground before Hook can communicate with it. (Apple does not provide a blank “allow Hook to work across apps”.) All Hook needs to do is get the number of links if the app is supported. We’ll revisit whether we can exclude a bunch of apps, keeping in mind that Hook works with many apps by default without Hook having a specific script for them and there are many apps out there.

If the feature is too annoying, we recommend turning off the feature from Hook’s general preferences or command line. If for some reason it is not sticking, try toggling “unchecked, checked, unchecked” (though in our test it works and in public beta it worked).

This release using Agenda 14.1.1 (231) seems to break one of my automations set up to create OmniFocus tasks from checkbox lines of Hook notes. I now get an error “Cannot continue bookmark from active window. (-1708)” from the following AppleScript with Agenda as the selected window:

tell application "Hook"
	set theBookmark to bookmark from active window
	return "[" & theBookmark's name & "](" & theBookmark's address & ")"
end tell

oh! We switched Hook automation of agenda to use x-callback-url. There’s an issue currently with bookmark from active window with apps controlled with x-callback-url that is slated to be resolved in 3.7 or 3.8. The work-around for now is to revert to the prior Hook > Agenda > Get Address script:

set the clipboard to ""
tell application "System Events"
    
    tell process id "com.momenta.agenda.macos"
        keystroke "l" using {command down, shift down}
    end tell
    
    repeat 50 times -- poll clipboard for ~2.5 seconds
        try
            if (the clipboard) is not equal to "" then
                exit repeat
            end if
        end try
        delay 0.05
    end repeat
    
end tell

set addr to (the clipboard as text)

set myTitle to «class ut16» of (the clipboard as record)

get "[" & myTitle & "](" & addr & ")"

Sorry for the inconvenience.

this is now addressed in Hook 3.6.1 beta: improves hooked status indicator in menu bar icon - Releases - Hook Productivity Forum. I recommend we continue the discussion there.