Hook 3.5 Public Beta is now available for download

Hook 3.5 Public Beta is now available for download from its Release Notes page. Our betas are not distributed as in-app updates.

  • It is now possible to delete bookmarks
  • We’ve renamed the “Delete Link” command in HOOKED section [“Unhook Link”.
  • there are other fixes and enhancements per the release notes.

Gratitude: Thanks to feedback via this forum and via email. Some of it is incorporated in this release, and more in the pipeline.

Also : please let us know if you discover any new issues specific to this release, or some of the fixes don’t work for you. And of course we’re always open to feedback regarding the rest.

The new version works great! I ran into a little bug: Obsidian bookmarks don’t look like can be deleted.

Good catch! Thank you @yuying . I replicated this with regular obsidian URLs but not with obsidian://advanced-uri URIs.

@LucB Thank you for your reply. I met this with obsidian://advanced-uri URIs :joy:

Two of us here at CogSci Apps Corp. have tried and so far we can only reproduce this with obsidian://advanced-uri URIs. Can you please share a Markdown URL with us that is persisting on your side. You can use a PM to support or here. Please use the code button above , or use ticks ``` ('ticks) to make sure the text is literally displayed. Thank you.

@LucB Thanks, here are two examples:

[玩转 Obsidian](obsidian://open?vault=Md%20%E6%96%87%E6%A1%A3&file=1-%E5%AD%A6%E4%B9%A0%E7%AC%94%E8%AE%B0%2F%E7%A7%91%E7%A0%94%E7%94%9F%E6%B4%BB%2F%E7%8E%A9%E8%BD%AC%20Obsidian)

I can’t delete both of them.

Another weird thing is that if I get the Obsidian bookmark( it is obsidian://advanced-uri) in the current version, I can delete it.

do you mean you can’t delete them from search view but can delete them from hooked items section?

Thank you, I don’t mean that. I can’t delete obsidian bookmarks which were created in past versions from search view or hooked items section, but I can delete obsidian bookmarks which are created in the beta version.

1 Like

I am on 3.5 and Hook will shutdown (crash?) after a few minutes. I can restart it and then it will crash again - even when I am not using it at the time. I’m guessing that something is going wrong during syncing.

Suggestions? Thanks in advance.

EDIT: I did and export/import and Hook isn’t crashing anymore. But I do have a discrepancy of about 300 hooks more on the Mac than I have on the iPad.

Thanks for letting us know, @arthurwerry . We’ll investigate the crash reports.

I’ll follow up in the TestFlight forum category.

Hook Version 3.5 public BETA 2 (4712, Integration v. 208) is now available for download and testing.

changes specifically in Public beta 2

  • Fixed a performance issue
  • Improved experience on Twitter
  • Integration updates and additions for Obsidian app, Notenik app, Trello app, Bear app, BusyCal app, and Zotero app.
  • Improved compatibility with Hook for iOS/iPadOS (still only available in TestFlight as of 2022-04-02).

This issue is fixed in Hook 3.5 official release, due this week.

Closing this topic because Hook Version 3.5 (4736), integration v. 206 is now available.