[FIXED] In Non-English language - nvALT Integration doesn't work properly

dear all,
I’m a huge fan of Hook, and also an intensive user of nvALT. I’ve read the posts about how to use Hook w/ nvAL without understanding if the integration runs smoothly. In my case (I’ve a file-based nvALT, all my notes are in a folder, not a database), when I’m triggering Hook from an nvALT window, Hook says “no valid resource detected” (see attachment). To succeed I’ve first to display the .txt note, which isn’t so convenient.
Somebody said somewhere that since nvALT automatically saves files, this would enable Hook’s files hooking, but apparently doesn’t


thx!
best,
P.G.

Thank you for reporting this issue, P.G.

Files do need to be stored on disk before Hook (or anything else) can link to them (a file doesn’t have a pathname until it is stored). Based on the Hook window screenshot, it seems that the file is not saved. However, based on the nvALT window, it looks like the file is saved (because there’s content there and a title). What is the procedure for getting nvALT in the state that you’ve displayed? I’ll try to replicate that.

I’m using nvALT Version 2.2.8 (128) on macOS Mojave 10.14.3 (I had qualified it on previous versions of macOS). However, CogSci Apps can run some tests on an earlier version of macOS if that is what you are using.

(We recently introduced and in build 2014 fixed a linking issue with nvALT. But that’s not what you’re reporting.)

Luc

Dear Luc,
I’m on Mojave 10.14.2, w/ the same version of nvALT you’ve (2.2.8-128). My files are stored in Library/Application Support (this may have an impact). Notice the previous fixed bug, seems unrelated to this one;
thx!
best
PG

It’s working for me with nvAlt files stored on Dropbox, OS X 10.13.6.

I tried this configuration, and several other nvALT configurations, and I haven’t been able to replicate the issue. Again, there seems to be an incompatibility between the nvALT window screenshot and both the text and Hook window in the screenshot. In the nvALT screenshot the file is saved. And when the file is saved, Hook should be able to get the URL from nvALT.

Could you please try nvALT> Edit (menu) > “Copy URL” (menu item). If the result is not a URI, then that means the issue is with nvALT (or that nvALT is behaving as its developer intends). Hook can only get a URI if nvALT will return one.

Again, that is the intended behavior. Without selecting a note saved, Hook cannot get the address (nvALT URI) of the note.

dear Luc,
when I do “Copy URL” I get a URI (“nvalt://find/“ form), but from within nvALT Hook cannot get this URI to compose a link. As I told you, the only way is to display, thru the Finder, the actual .txt note. You said that it’s the intended behavior, but to my humble opinion you cannot say that Hook is nvALT-compliant: it’s only Finder-compliant!
I regret this, since I’m an intensive user of nvALT.
btw, I’ve been reading your pricing plan. My opinion is that 1/ this plan is hardly understandable; 2 levels only, “free” and “standard“, the latter with all the facilities, would be clearer. 2/ the “pro“ price is too high.

thx & best,
ph

Thank you, P.,

Sorry: My earlier response was based on my misunderstanding of what you had written. I thought you were saying that you first have to save the note in nvALT. I didn’t mean to imply that Hook only works from Finder. Once a file is saved via nvALT (which it does as soon as you start writing in the note), the Hook window can get the note’s address. I.e., the Hook window is populated in the context of nvALT, so long as the current note is selected.

Here are a couple of screenshots: to illustrate the difference:

I suspect in the case you are encountering, for some reason nvALT loses “focus”. I.e., a nvALT note can in principle be selected in nvALT while the nvALT note editing window does not have “focus” (even though it may seem to be in the foreground). In earlier development of Hook, we had this issue with an app (a web browser I believe), and resolved it. For nvALT to have the focus, to the right of the Apple menu you should see nvALT as the next menu; but even if the nvALT menu is present, it is theoretically possible for the nvALT window not to have focus.

(I have tested Hook in both horizontal and vertical layouts.)

Thanks also for your feedback on the pricing. We will continue to assess and tweak the distribution of features between Essentials and Pro, and we will try to simplify them and make it all clearer.

(Timing.app and OmniOutliner both successfully have tiers, which allows companies to enable users who don’t need as much power still to benefit from the app, while sustaining product development.)

Hopefully presenting a tier X feature table will also help.

dear Luc,
thx for your comprehensive reply; no idea why my config. of nvALT doesn’t work with Hook; will try to put all the files in another place and tell you if it works.
best,
ph

Thanks, PH. It occurred to me that perhaps there is another service or process that is responding to the shortcut for the Hook window in the context of nvALT. If it did this, normally the Hook window should not appear at all, as it would “consume” that event. But it might be worth trying to assign a different shortcut for Hook (in its Preferences>Shortcuts tab) to see if that makes a difference.
Luc

dear Luc,
tried w/ several complicated shortcuts, without success; even the menu-based function doesn’t work. I keep you informed if an idea arise;
best!
ph

Hi. I’m pretty sure this doesn’t help but I have tried linking an existing nvALT note to a note in Apple Notes and also a newly created test NVALT note to the same note in Apple Notes and everything works as expected. Links are set up correctly and work both ways…
I’m happy.

Dear John,
thx for reactivating that thread; I’ve the latest version of Hook and on my Mac (MacOS 10.14.4) and nvALT elements cannot be linked thru Hook yet; (Notes files can be linked only when they’re in a specific window (double-clicked).
no idea why, so far,
best,
ph

Thank you all for persisting. And I’m sorry it took so long for us @ CogSci Apps to get to what might be at the heart of this issue: Is your macOS display language not set to German? That would explain issues with nvALT, and other apps with which Hook communicates via UI scripting.

If your language setting is in face non-English, then a quick test would be to switch your macOS display language to English, and quitting and relaunching each app in question.

For a a fix: the short answer is you can make Hook work with nvALT by replacing “Copy URL” with “URL Kopieren” if German, or “Copier URL” (for French), in (in Hook > Preferences > Script Editor tab > nvALT (script bundle) > “Get Address” tab (script)). If it’s a different language, just use whatever display you see in the “Edit” menu.

If that does not solve the issue, please do let us know.

Background and plans

During beta and for the 1.0 Golden Master (GM), we have been focusing almost exclusively on supporting English. (We addressed non-English issues here and there as they arose.)

Our plan is to internationalize Hook soon after 1.0 Golden Master. That in itself is coming soon. Internationalizing Hook is special compared to other apps, because Hook integrates with many apps, some of which can (currently) only be controlled via UI scripting. UI elements on which Hook relies differ in non-English cases from what we’ve packaged so far in Hook. So we will need to “internationalize” each UI scripted app.

We’ve posted some new information about this:

As Hook becomes more popular, it is our hope that more and more third-party app vendors will see the value of providing the automation support required by Hook (and other apps for that matter). Compare: Contacting developers of other apps – Hook.

dear Luc,
thx for this comprehensive answer; lots of things to investigate and likely good paths.

but I’ve just uninstalled Hook because, all in all, I’m not using it so often… and I plan to rely on DevonThink 3.0 to manage such links bet. files (and, frankly, I think that the pro version of Hook is a bit too expensive). If I finally decide to reinstall Hook I surely follow your advice!

I wish you plenty of success with that pretty piece of software,

ph

Le ven. 24 mai 2019 à 08:15, Luc P. Beaudoin via Hook Productivity Forum noreply@discourse.hookproductivity.com a écrit :

Thanks for the good wishes, @pgrepon.

I’ve renamed this topic to reflect the fact that it’s a language limitation. The next release of Hook will include our underlying script internationalization framework.

This issue is fixed in build 2498 for French. The German fix will be in the next release.

For other languages, users can also add the translations of leveraged UI commands in Hook > Preferences > Scripts tab.