[DONE, but investigating issue] Any possibilities for Ulysses integration?

#1

I’ve been using Ulysses a lot lately, and I’ve really liked the integration with OmniFocus, which allows me to use a Keyboard Maestro create an OmniFocus task with a direct link to a “sheet” in Ulysses, using Ulysses’s “Copy Callback URL” function.

But Ulysses doesn’t seem to be supported in Hook.

Hook Version 1.0-beta (2115) is now available (built 2019-03-07)
#2

thanks for asking! We are about to contact the developer to ask them for some AppleScript:
Contacting developers of other apps – Hook. Hopefully they will oblige, as it is very easy – I also use Ulysses for some of my writing, so it would come in handy.

2 Likes
#3

Great to hear! Let’s hope they’re willing to play along!

P.S.: I love your app MySleepButton, by the way. I’ve just finished a 5-year study on what I’ve dubbed “Bedtime Procrastination”. You’ve made a real societal contribution with that app.

1 Like
#4

Super. if you could send me the URL, PDF or title of the paper at some point that would be great.

I’m still active in sleep onset and insomnolence. We’ve had a paper accepted http://www.sfu.ca/~lpb/pubs.html with modifications @ Sleep Medicine Reviews . And wrote two new theoretical papers that we need to get published.

#5

I’ve used Hook a LOT for my academic work in the last couple of years. It’s great to get it out into the wild!

#6

Cool! Have a look at my Research Gate page; if there’s something there you can’t access, feel free to let me know.

#7

We’re getting a lot of requests via email etc. for integration with Ulysses. For the sake of new users finding this post, I note again that Ulysses lacks requisite Applescript.

However, we have recently asked Ulysses’ developer for it using thee Ulysses Contact form. On Twitter they are: Ulysses (@ulyssesapp) | Twitter.

If Hook+Ulysses users would like the following tweet, it might help the Ulysses developer prioritize this: Hook: Mac productivity app on Twitter: “We’re getting a LOT of requests (via Hook’s forum and email) for Hook to work with @ulyssesapp as it does with many apps. It would need minimal AppleScript. Could you please provide some?” (links redacted ).

FYI Our integration tips for developers are here: Integration – Hook

(Hook works with many Markdown-enabled apps, such as Marked 2, MailMate, BBEdit, Bear and MultiMarkdown Composer).

#8

Following on @AutonomyGaps’ original post. You might be able to work something using Ulysses’ x-callback-url support. You can have System Events press-hold ⌥ then press ^⌘C then press “Copy Callback URL” to get the ulysses:// URL for the current sheet (i.e., a “note”) in Ulysses.

1 Like
#9

Thank you, we are on it. We should have something very soon.
The Ulysses team also kindly pointed us to their x-callback, which I hadn’t noticed.

2 Likes
#10

FYI, if all goes well, we will release a build with Ulysses support on March 7 (Pacific time, as always).

#11

Ulysses support is now included in Hook Version 1.0-beta (2155) - Releases - Hook Productivity Forum.

I have not personally checked this with the new version of Ulysses coming out of beta soon.

[FIXED] To invoke Hook window in Ulysses one needs to select the doc in the Sheets column (not put the focus in editor). A bug with Ulysses
#12

Brilliant! Thanks so much. Ulysses linking is working beautifully now. I’m running the Golden Master Beta for Ulysses 15.

#13

No joy with Hook b2155 with Ulysses 14.4 on macOS 10.14.3

I gave Hook permission to control Hook when first prompted.

[FIXED] To invoke Hook window in Ulysses one needs to select the doc in the Sheets column (not put the focus in editor). A bug with Ulysses
#14

My bad, the latest release is actually build 2115.

Worked well yesterday. However, I noticed this the first time I tried to invoke Hook on a Ulysses document this morning. Subsequent attempts worked fine. In my case, it looks like it was a timing issue.

#15

Could be, but I’ve been trying it for a while now and it continues to error out.

Just on the off chance I had done something wrong, I reset Ulysses and System Events in the privacy database. No luck.

I happen to be using the Setapp instance of Ulysses – same version; different bundle ID than the regular instance. It’s possible that’s a problem. You might want to use the “ULY3” app ID in your script, if you’re not already doing that.

Never mind – changing the ID in the script doesn’t make it work.

[FIXED] To invoke Hook window in Ulysses one needs to select the doc in the Sheets column (not put the focus in editor). A bug with Ulysses
#16

I’ve tried repeatedly for days to get the Hook-Ulysses integration working. I even reset the entire privacy database on this Mac – an action that takes a very long time to recover from – with no luck. The has to be something wrong with the script.

I wouldn’t consider this request “[DONE]”. Sorry. :frowning_face: Did anyone at Soulmen actually try this?

[FIXED] To invoke Hook window in Ulysses one needs to select the doc in the Sheets column (not put the focus in editor). A bug with Ulysses
#17

Thanks for reporting and investigating this, @quorm. I’ve logged this bug report for tracking this issue: Ulysses integration not working for some users - Bug Reports - Hook Productivity Forum.

They acknowledged the integration in a Tweet, but have not indicated to me that they are using Hook. Now that there Beta is over, I assume/hope they’ll be able to look at Hook.

changing the title, but tracking it with a separate bug report will be easier (more focused) and Ulysses users will hopefully find it in the Bug Report section and hopefully contribute to the topic.

#18

You’re terrific! Thanks.

1 Like
#19

Ulysses 15 was released today.

Sad to say, the Hook integration doesn’t work for me in v15 either. :frowning:

#20

Just to link if people looking here haven’t seen, I’ve posted a suggested addition to the built in handling here which may help with your issues: To invoke Hook window in Ulysses one needs to select the doc in the Sheets column (not put the focus in editor). A bug with Ulysses