Build 2372 of Hook Version 1.0-beta is now available

Hook Version 1.0-beta (build 2372) is now available for download via Hook’s download page and Hook’s in app update mechanism.

Hook Version 1.0-beta (build 2372) is now available for download via Hook’s download page and Hook’s in app update mechanism.


  • Fixed a problem introduced during public beta such that links to shared files (such as those shared via Dropbox) would not open on other devices. (Issue 3403)
  • Fixed an occasional graphic glitch with the menu bar window’s bottom well. (Issue 3342)
  • Further optimized Ulysses script. (Issue 3402)


  • Improved efficiency of opening hook://mail links in Airmail. (Issue 3380).
  • Improved wording of Hook window’s status bar message (at bottom of window) for cases in which Hook is invoked when no addressable resource has been selected or (can be) returned by the foreground app (including currently unsupported apps). “No valid resource detected”. (Issue 3286)
  • Further improved support for BusyCal. It is now more efficient than with Calendar app, making BusyCal our recommended calendar app. (Issue 3345)
  • Clicking “Learn more” in Hook’s authorization assistant now quits Hook. (Issue 3406)
  • Changes in preparation for Hook’s upcoming exit from 1.0 public beta and reaching golden master. (Issue 3373)
  • Improved integration of Hook with its script service to detect and handle compatibility mismatches. (Issue 3397)
  • Split date-time column of ~/Library/Application\ Support/com.cogsciapps.hook/log.csv file into two columns (introducing a comma), so spreadsheets can parse it more easily. (Issue 3313).


Thank you to all users who reported issues through Hook Forum or other channels.

Revision history of this topic

I extended these notes today ( 2019-05-15). They go beyond the DMG (I had forgotten some changes).

Since this is beta software, we did not include code to reformat prior log entries (and this is in ~/Library) So you will notice a change in the schema, where the new column is added.

This update has broken Ulysses integration for me (App Store version).

Links to Ulysses open but trying to invoke Hook in Ulysses is saying no item detected.

Gi Steve. Am not at my Mac at moment but did you update to macOS 10.14.5? If so, did other apps misbehave after that?
Does relaunching Hook help?

I’m still on 10.14.4

Nothing else strange I’ve noticed — I have installed some new apps so if no one else has this problem that could be why. I can try on my other mac later to see if same issue there.

I’ve tried a system reboot and resetting Ulysses scripts to default.

I tried rolling my Ulysses scripts back to my semi-custom ones and it’s working now, so the issue seems to be in the built-in scripts rather than main Hook code.

The offending code seems to be:


should be:


For the App Store version.

that was meant to be “Hi Steve”.

Sorry for the delay in responding. And thank you for bringing this to our attention. I have tested with build 2372 and the Hook window came up blank, confirming the issue. In the current internal build it is fine. Normally we would deliver the update via the Hook integration server, but during this part of the beta phase it’s unavailable. We’ll patch this in the next update, which we’ll accelerate.

Very sorry for the inconvenience.

1 Like