VLC application cannot be found by Hook

I just noticed that, as I am studying a video using the video player VLC, that Hook was unable to recognize the application VLC. When I tried making a link to the running video, Hook asked, where is the application VLC located? So I went to the VLC app. But, VLC was faded out and could not be selected in a Hook menu.

I mention this in case it is of any use to Luc or to anyone. The situation was easily resolved as I made a Hook link to the file its self. Setting this file in a Hook menu launches the file which opens by default with VLC.

Perhaps I have not fully understood everything yet about using Hook but it would seem that Hook should have linked to an open video file. On the other hand, Hook cannot link to an open HoudahSpot file either (as the working file and not meaning a single item selected). Perhaps this is just my misunderstanding of how Hook operates but, as the VLC file could not be found by Hook, I felt it was worth mentioning.

Could you please upload a screenshot?

The current conditions for linking to particular resource are listed in No Linkable Item in – Hook.

Hook can link to the open HoudahSpot search if the search is a HoudahSpot file that you have saved and you have deselected any search result.

FYI: HoudahSpot has a bunch of built in searches which are not treated by HoudahSpot as files ( HoudahSpot does not expose their address). Hence Hook cannot link to them (nor could other apps).

To link to HoudahSpot searches you first need to create them and save them. Then make sure you deselect search results, otherwise Hook will default to linking to the selected item .

This is what I get when I run a HoudahSpot search and deselect any files so only HoudahSpot search is present. In this example there are 20 found files. The Hook menu says there are no likable file however. You are looking at the top two items in the found set of 20.

I just tried this again on a VLC file and this time, it worked. I will continue to test with different file formats. Some of the videos are DVDs, most are mp4 files. The one with mp4 did work just now. I did not take a screen shot of the earlier problem. When it returns - if it returns, I will capture a screen shot of it.

Thank you, @levelbest. Is this based on a builtin (“Sample”) HoudahSpot template that you have not saved as a separate file? Or is this based on a HoudahSpot search file?

If, in HoudahSpot 5, you use “Save” or “Save As”, you should get a file whose results you can link from.

That’s interesting, I thought that a search and a template file were the same. You are correct, saving a HoudahSpot saved search or saved as search file does work.

Doing the same thing on an open template file, will not. And, it Hooks back to other files too. Something I thought I could not do with HoudahSpot.