The Brain 12 Beta

Hi - I see that Hook has scripts for The Brain - which could be very helpful

Brain Beta 12 has been released

When I try to create a hook I get this error:


Thoughts on how to edit the Script to work with this new version?

Hook relies on UI scripting for integration with The Brain because The Brain lacks automation.

They must have changed the Edit menu in v. 12 Beta. We will have a look. (If someone wants to first share a screenshot of the Edit menu before a dev here gets to it, I will do a quick comparison with the script).

Thank you @LucB

I just went to take a screenshot and it seems they issued a new beta version today. Now it works fine with Hook. So problem solved.

1 Like

Hook is working well with TheBrain, the most recent beta.


1 Like

Well, things changed. Hook 2.0.3 is not working with TheBrain, now the most recent beta.

Screenshot of Hook (11-19-20, 10-17-13 AM)

TheBrain is pretty fragile software sometimes, unfortunately – not a good macOS citizen.

Katie :frowning_face_with_open_mouth:

Thanks for letting us know, @katie_v

meaning the issue is only known to occur with its current beta as opposed to public release?

This would be a good one for us to find a liaison. I’ll ask internally.

TheBrain 12 is only available as a public beta – it is not in production release.


1 Like

Update. Hook is working again with TheBrain v12.0.36.0. (Current alpha released to beta testings – yes, the terminology is confusing, but beta users can access the “alpha” channel for updates. It’s not private. Here’s the link).


1 Like

Hi. Anyone want to comment on how they are using Hook with TheBrain12 (I’m at 12. 0.45). So far I have only placed Hook links within the Notes section linking to a folder in Finder. TheBrain only allows the link to be placed within a group of links at the top of the Notes editor. I would like to figure out how to place Hook links within the body of the Notes written in the editor.

Not for me. I just paste the hook://.... link into the text of the note, and TheBrain inserts a markdown link correctly, not as an attachment. (The “group of links at the top of the Notes editor” are attachments – but TheBrain, for me, doesn’t put the Hook link into attachments unless I use Attach > Link to URL).


1 Like

Thank you, Katie. Not working for me.

Hook: select a document > copy link with Hook >
In TheBrain: select a word within a Thought Note > insert Thought or Web Link > paste
The paste will give me the name of the document and not the Hook address.

@katie_v Figured it out. I have to “Attach Link to URL” by using the pulldown menu. Going to setup a short cut. Thank you.

1 Like

Actually, no. Just paste the link directly into the body text of the note. You don’t need to use “Insert link” with this or any other custom URI links or standard HTTPS links.


Right. I am understanding now how Hook works. Thanks.

FWIW, it’s broken again. No bidirectional links. image

I do hope that eventually TheBrain gets its act together with an API. I finally gave up on UI scripting TheBrain. I get tired of broken code. However TheBrain does allow you to set a keyboard trigger for almost everything it does. Set something like “Copy Local Thought URL” to an out of the way keystroke and then automate away by simulating the keystroke.

(“Out of the way” keystrokes can be an issue. I don’t have a keypad, so use Keyboard Maestro to emulate any of the 255 possible combinations of modifiers and keypad keys to do things like this.)

But still no joy in Mudville as far as seamless use of Hook and TheBrain 12 Beta.

I am on TheBrain, the current beta version, and Hook works with that version most of the time. Occasionally it fails with the error you posted. It fails when that menu item (Edit > Copy as Text Outline) is disabled / greyed out. That seems to occur when TheBrain is syncing itself to its cloud service – but I can neither prove that or reproduce.

Anyway, Hook is working with TheBrain 12, but sometimes it does not. Not great or good, but re-trying does always succeed.

Katie :frowning:

1 Like

Someone mentioned to me that theBrain’s devs have pledged to produce an API. That would help.

The question of when would there be a public API for TheBrain used to come up frequently in their user forum. The company stopped promising it several years ago. I wouldn’t hold my breath.


1 Like