Some Hooked Notes in iCloud not immediately bidirectional

Summary - My Hook Notes files are not showing links to their source (webpages, in my tests)… at least not immediately. I have to restart Hook for the links to show.

I am using v3 of Hook and Safari. I have my default Hook to New as a text file, that gets saved to Hook Notes.

In a webpage, I’ll invoke Hook, cmd-n, type a note and close the file. When in invoke Hook, again, on the webpage, I can see that the note file is linked.

If I go to the note file, select it, and invoke Hook, I do not see the link to the webpage.

Update, 12 hrs later… the notes I made via hook this AM are now showing the links to their source webpages. But… notes I created just now, are not.

So, I restarted Hook and checked again. I can now see the links to the webpages from the notes.

Hi John,

  • What note-taking app are you using?
  • also , where are the notes stored ?
  • what version of macOS?
  • model/speed of computer?
  • is anything renaming or moving the files behind the scenes (like Hazel)?



TextEdit. I’m using the default new note setup. And, these are creating plain text files (not RTF, etc.)

~/Documents/Resources/Hook Notes
(I’m playing with the P.A.R.A method)

Note - I enabled the Desktop/Documents on iCloud feature about a week ago.

Big Sur 11.3

2017 iMac w/64GB RAM

No. I do use Hazel, but not for these files in this folder. Just to be sure, I disabled Hazel completely and ran the same test as above. Same results.

Maybe that’s it. I’m renaming the bug to draw attention to that. If it happens on non-iCloud please let us know.

It may be that iCloud has started offloading these files in a “problematic” way. (Apple does not document iCloud updates the way it documents macOS updates). Hook has some code that makes its bookmarks adaptive in several ways, so that when files disappear and re-appear it can re-attach them for instance.

I reverted to 2.2.2 and the issues resolved themselves. And, the issues did not return in 3.1. So, I’m fine, now, on 3.1.

1 Like

Super! thanks for letting us know.