[solved] No longer usable after BigSur update [related to fig CLI]

Since Big Sure update for the M1 chip macbook pro, Hook no longer sees it has permissions even though it is check in the System Preferences dialog. Several program are having this issue and it is driving my nuts.

Big Sur 11.6 (20G165)
MacBook Pro (13-inch, M1, 2020)
Hook: latest version and each beta has been tested.

Sorry about this.

Is there any error message or Hook just says no linkable item found?

Could you please check the following web page and see if it helps?

Sometimes the accessibility permission database can be corrupted. You can find solution in the above link

Thank you and sorry about this

The problem isn’t about a linkable item. It’s the program refuses to run at all until it has permissions in the System Preferences->Security & Privacy->Accessibility. It is checked there, but Hook refuses to believe it is checked. Therefore, it will not run.

This happened right after I upgraded my Big Sur to the latest version as mentioned in the first email.


When Hook asks for accessibility, could you please uncheck the accessibility, and then check again? See if it helps.

Thank you

Like I’ve said, I’ve done that several times. A couple of times with a system reboot afterwards. I’ve even unchecked it, rebooted, checked it, and rebooted. It still says it isn’t setup and will not run.

Sorry but just want to make sure, have you tried the following command in the aforementioned link:

  1. tccutil reset Accessibility com.cogsciapps.hook
  2. reboot your Mac.

The problem is also mentioned here:

Actually, I finally figured it out. It was a problem with another program, fig. I deleted fig and everythings gone back to normal. Considering fig is a terminal program that give completions, I have no idea how it messed up other programs. So, if anyone else complains that Hook started acting funny, ask them if they have fig installed.


1 Like

Thank you for letting us know! I am glad you solved this problem.