[resolved 2020-11-12] License activation errors

Hi, I bough Hook Pro on oct 8 2020. Today After upgrade to hook 2.0.1 today, I cannot reactivate. When I open the tool I receive the following message:

Hook Activation failed (status Code 500)
internal server error.

2020-11-11_22-31-41

If I check the version, I have a Lite in trial mode.

I use hook a LOT. some help please?

Thank you!

-Alex

Thanks for letting us know, @AlxRlja. I will respond by PM in terms of the transaction details.

1 Like

Same problem here

When I go to activate it with the original URL, I get:

image

1 Like

Thanks for letting us know. This indicates there is a non-isolated issue with the license activation. It’s a top priority.

2 Likes

Second that, same error message.

  1. Hook appears in the menu bar, but disappears when I click on it.
  2. When I click on a Hook file, the target file opens, and the menu bar item appears, too.
  3. I checked - I can still link files and create Hook files, just with the occasional error message popping up.
    Thanks for looking into this, Hans

this seems to be a different issue as it does not refer to license activation, correct?

One of the software services involved in this is down. So we’ve temporarily suspended Hook 2.0 in-app updating until we get to the bottom of this highest priority issue.

I’ve renamed this topic to “License activation errors” because it’s more generally.

This is very likely a side effect of Dreamhost upgrading its OS on our instance.

If anyone is a Hook 1.8 user who upgraded to Hook and is delayed by this license activation issue, you can try this: Reverting to Prior Versions of Hook – Hook.

We’ve added a Status banner to the website, and a Service Status – Hook page that you can check.

1 Like

Not sure. The error message “Hook Activation failed / Internal Server Error” appears throughout. I’ll let you know if the issue persists after that software service you mentioned is back up.

Thanks!

Hans

we can confirm that DreamHost’s update of the OS of our servers had consequences we did not expect on our systems. We are ‘all hands on deck’ here working on restoring services and making progress one by one. Status is here https://hookproductivity.com/service-status/ and I will update this topic when this is resolved. We extremely regret this inconvenience.

We believe the issue is now solved.
if you continue to have problems please let us know.
more updates to follow

Hi Hans,

Hook 2.0.1 is available again, and our license server is back up. We are VERY sorry for the earlier inconvenience.

Thanks again for letting us know about this urgent issue.

if you encounter issues again please let us know.

best regards,

Luc

1 Like

Haha… I had to delete the current Hook version, and installed Hook 1.8 just 5 min ago (the revert-to-hook app gave me an error message). I’ll try again!

Thanks, Hans

Ha, works fine now. Thanks, Hans

1 Like

yes!, now all is working correctly. Thank you! :smile:

1 Like