Renaming pinned bookmarks

I have bookmarks pinned where renaming the item will update the name in the pin list but not when focused on that item; or where renaming the item will update the name when focused but not in the pinned list. The rename appears to work when done, but as soon as Hook window is reopened the bug appears.

I also now can’t unpin the item (again, it updates when done but then reappears).

Sounds like a corrupted db?

Edit: It may be related the unremovable/unnamable item was a Hook file that resolves to a URL. The other rename issue was with a Hook file to a local PDF.

Edit 2: I also have a URL pinned that I cannot unpin — this is possibly related.

Has anyone else had same issue?

Just posted this - we must have been typing simultaneously

Thanks for letting us know about this issue, Steve. And sorry for the delay.

We’re investigating whether an issue was introduced in 2.1. Meanwhile, we would recommend the following export/import procedure to clear up any issues with the database
General Preferences Tab – Hook.

If your Macs are all Sync’d you can do the following on just one Mac, and use that Mac as the basis for syncing the others. If not all Macs have access to the same file systems, you’ll want to repeat on each Mac.

  • Step 0: Turn off Sync and Quit Hook.
  • Step 1: Make a backup copy of ~/Library/Application Support/com.cogsciapps.hook in case you make a mistake or system crashes during the process.
  • Step 2: Make sure all external mount points (disks, cloud shares, version control systems) are connected because bookmarks (and hence hooks) to unreachable hook://file// destinations will be removed)
  • Step 3: Relaunch Hook and go to Hook >Preferences (window) > General tab, click on the Export button and follow the instructions.
  • Step 4: once Export finishes, click on Import button.

Re-enable Sync once you’re done.

1 Like

I’ll give that a try on Monday.

This solution has worked for me. :+1:

1 Like

Thanks, Steve. Sorry the trouble was required. One of us here has tried to reproduce renaming issues, but so far not able possibly because it was fixed in the new internal builds. However, we are not finished our investigation ; we aim to ensure this is dealt with for 2.3.

We also intend to make related improvements to renaming and various menus. E.g., there should be a “rename” menu entry in the Title menu too. All the major menus in Hook (Title, Link, Bookmark [Find] menus) should contain all the applicable commands so that the user has a consistent experience. And we have additional related features to add.

1 Like