Problem with Samba Shares

I try to link files on my Synology NAS. I work with a Macbook Pro (Sonoma).

I’m not quite sure, what the real problem is, but after I reconnect to my share, I can create a link once. If I try it a second time, it only links the finder and I cannot work with the files anymore (not just linking). Then I have to reconnect to my share.

When I drag the files into the hookmark window, I have the same issue. It work once and after that it even crashes the app.

I rather think it is an issue with my mac and the nas, but maybe somebody has an idea, what I can do. thnx Markus

I just found out, that it only happens with files that have special characters in the filename.

Sorry about this issue, @Netfly .

Could you please post some example file names here?

Thank you

failing files:

  • “Blitzkarten Einführung Small.mp4”
  • “2023-02-16_Söhnetreffen.mp3”

working files:

  • “2023-01-23_DiscipleshipA-2.m4a”

Thank you for the info, @Netfly .

Sorry I forgot to ask, what’s your Hookmark version(in Hookmark about window) and macOS version?

I tried to reproduce the problem, but no luck yet.Perhaps we did it in different ways. Could you please send us some screen shots which can illustrate the problem? A small vedio file is even better.
You can send it to support@cogsciapps.com.

Also , regarding the crashes, did you send the crash report to App center? If yes, could you please let us know the date and time, roughly? If not, you can find the crash report in Console->Crash Reports? Could you please send us the reports?

Thank you

macOS: Sonoma 14.5 (23F79)
Hookmark: Version 6.1 (5967; Integration v. 327)

And I just tried it again and it crashed on the second link
(One minute ago)

I will record a video and send it to you

Sorry, I didn’t had time to make the screen recording, but just a little update. Since I updated to 6.2, the App crashes every single time, when I drag a file with special characters to the hookmark app. Not just the second time.

Sorry for the trouble. Could you please tell us whare special characters are in the file name?

see a few posts before :wink:
Just “normal” german characters like ä, ö, ü, ß, etc.

Just to clarify … it only happens, when I use files from my samba share. Not directly on my mac.

What I heared, is, that Synology uses UTF-16 and Mac UTF-8. But I activated a setting to fixe this. But still doesn’t work.
As I said. I think it’s an issue of synology-samba-mac and not of hookmark. But the crash still should not happen.

Thank you, @Netfly .

Could you please help us debug the problem? Here is the steps:

(1)In /Applications/Utilities/Terminal, run the following command
defaults write com.cogsciapps.hook output.log.to.file 1
(2)Download a new Hookmark build here:
https://hookproductivity.com/wp-content/uploads/2024/06/Hookmark-app-6.2.1.dmg_.zip and install it
(3)Launch Hookmark
(4)Make Hookmark crash by dragging the file with special characters to Hookmark window(or any file that can crash Hookmark)
(4)Send us the log file at "/Users/YOURUSERNAME/Library/Logs/com.cogsciapps.hook/“ to support@cogsciapps.com after the crash.

Thank you