Paste link to Search result

Currently I need to copy a link to file A with Hook, find/open file B to paste file’s A link to it. But in many situations file B is already in Hook’s database, linked to other resources and I can find it in the Search feature.

I couldn’t find a way to paste that link from file A to the Search result without opening it, invoking Hook again and then pasting the link. Is it possible or did I just think about a feature request?

Select the result and press the right arrow key to navigate to that context, ready to paste and hook.

1 Like

Hi Steve. Unfortunately the Search results don’t accept going “inside them” by using the right arrow (on the UI or the keyboard). And they don’t accept Command+V also.

Disregard my previous reply, because I tried that in the regular window, which isn’t the Search Results one

1 Like

The right arrow triggers a Focus command. It’s listed in the menu of each search result.

I think CogSci Apps should add Hook to Copied Link, etc. to the search results menu.

There is a → in their menu, indicating the shortcut.
If pressing the right arrow key does not work, there’s a bug.

:one: Pressing the down arrow on the keyboard doesn’t move the focus from the search textbook to the results list (which is what I expected).

:two: Clicking with the mouse on the search result highlights it, but pressing the right arrow on the keyboard or the Focus arrow on the UI don’t do anything.

So I guess it’s two bugs :bug:.

missing feature rather than bug. But we do plan to add it.

Ah, if the search result is a bookmark with no hooks, you can’t focus in on it. (there are 2 schools of thought about whether it should).

Adding search results menu items would (will) solve that.

Great. I guess it’s already being implemented, because pressing the Command key on the keyboard shows ⌘0, ⌘1 shortcuts on the resuts.

In my case there is at least one existing hook for the search results.

:video_camera: Screen recording

thanks for that screencast. I’m logging a bug for it.

I think I see what is going on. I think this is a special case (which would still qualify as a bug, which I have logged, but rarer). You tried to ‘focus’ on a search result that was the focus when you invoked search.

If you can reproduce the issue for other items, please let us know.

@LucB It happens on other items also. I narrowed it down to this: it happens only to the first result.


@LucB is there a way I can paste only the link, not the title? my most workflow only require me to use the raw link, because I would modify the copied title anyway, so now I see I lack a way to only paste the raw link.

Ah! I just realized I can use the mac hotkey command+option+v to do it! However, it would be cool if Hook has option to either only copy raw or only paste raw (this might be on the mac side).

Welcome to the Hook Productivity Forum , @aaron_a . There’s plainClip app which “Removes formatting from copied text” : Projects | I’ve been using it forever.

  1. Hook’s Copy Link,
  2. through LaunchBar , Alfred or Spotlight, launch PlainClip

That could be strung into one with Keyboard Maestro.