No linkable item PDFPenPro

Have updated versions of Hook and PDFPenPro. I have run through all of the steps on No Linkable Item in … page on the Hook website. Hook works in other apps, for example, Safari, Word, but comes up dry in PDFPenPro. Have had this issue since day 1. Rarely on PDFPenPro. Reinstalling the apps makes no difference. Rebooting makes no difference. Running an M1 mac mini.

Tried Hook with the Skim PDF app. Same issue, sooooo a PDF thing? Perhaps that helps narrow things down in terms of my setup? Both PDFPenPro and Skim are check marked under the Hook App in Security and Privacy.

Welcome to the Hook Productivity Forum , @ThatCW. and thanks for reporting.

Could you please try

  1. in Finder on the same file.
  2. in Finder on a different file, with a .txt extension

also, are you using Hook 2.2 (latest)

another user, who is also using a M1 Mac, reported today: Hook not giving linkable item with TextEdit .
Thank you.

PDF file in Finder, Hook produces a link that opens the file. But, then when I highlight text in that same PDF file, no linkable item.

Identical results with .txt files.

Yes, using Hook 2.2.

You need to highlight some text in the file in PDFPenPro before activating Hook.

Then it will work.

Yes, thx, I do that - highlight text. And the files, 99.9999% PDFs, are always saved, too.

As I said in the previous reply, “But, then when I highlight text in that same PDF file, no linkable item.” Highlighting text and then bringing up Hook app isn’t working for me.

I can create links with Hook in Word files or Pages files, but usually not Txt or PDF files.

Notice I said “usually,” as I haven’t been able to get Hook to create links in PDF files for days. It worked at first - for about 2 hours when I downloaded it, installed the license, etc. - and it just started working again in PDFPenPro (just double-checked it to see).

But I still can NOT create links in TextEdit.

The only thing I did was reboot this morning, but that’s not anything different as I do that every morning b/c of the intermittent (usually overnight) screen lockup issue with Big Sur and the new M1 macminis. So, I have no idea what’s going on.

Thanks for taking the time to reply : )

So it works! Problem solved

Not all apps support deep linking - the vast majority do not do so yet. So those are all very different questions.

Well, I hope it sticks, but I’m not doing anything differently than before. As I said, it worked initially for a few hours, then didn’t for days, including most of today, then just started working this afternoon. So, maybe problem solved. I bought a PDFPenPro upgrade only b/c it was supposed to work reliably with Hook. Hope it continues.

It may be that you had Hook integration Scripts version 152, which was short lived and contained a change for PDFpenPro, which escaped my attention when I did the v 153 release notes. which also patched. If so, I apologize for the inconvenience.

1 Like

No worries. Awesome idea. I’ve been doing a poor man’s hack of this for a v long time with keyboard maestro, copying potentially usable text into drafts and rewrites, along with the doc title so I knew where it came from , but obviously no usable link. Then used HoudahSpot or Finder to locate that source. So thrilled to add Hook to my writing processes!

1 Like

Unfortunately, my “no linkable item” problems with Hook and PDFPenPro are back.

  • PDFs are saved.
  • Running latest scripts and version of Hook and PDFPenPro
  • I AM highlighting text in PDFs.
  • Hook works in Finder (on files that it DOES NOT work with on PDFPenPro).
  • Hook works in other apps, like Word.
  • Problem recurred last 4 days, both before and after the Mac OS Big Sur update.
  • Again, running an M1 Mac mini.

Ideas? Thanks.