No linkable item found in Obsidian

Hi, and Happy New Year.

I know we’ve been through this before, but no matter what I do I can’t get any response other than the above when I try to hook from an Obsidian document.

Any document, and I’ve tried quitting everything and restarting my Mac.

Hookmark Version 4.0 (4988; Integration v. 246) and Obsidian v1.1.9.

thank you, and to you!

Could you please do this at prompt:

% defaults read com.cogsciapps.hook | grep integration.obsidian

please be sure to hit the return key afterwards. Pls paste the result here.

then we’ll go through the relevant part of Using Hookmark with Obsidian.


$ defaults read com.cogsciapps.hook integration.obsidian.URL.scheme

I can’t replicate this on macOS 12.6.2 (21G320). Are you on a different macOS version? Has Obsidian had any significant changes?

The default integration, that you use, uses their x-callback-url, not plugins. But is it possible you installed some Obsidian plugin recently? or that one of your extra plugins (if you have any) has introduced an issue. Can you try disabling Obsidian plugins to see?

Someone reported the same issue to us. He said “it was a previously installed plugin that was somehow missing, so after reinstalling the plugin, the problem was solved”.

I doubt we are dealing with a bug. Hookmark has not changed in a relevant way, nor has Obsidian to my knowledge.

I’m on Mac OS 13.0.1 (22A400).No major changes to Obsidian, except that I recently updated the installer and activated the new Canvas core plugin. But that was after I started this discussion.

I just tried deactivating all the community plugins I have, then quitting and reopening Obsidian. No difference. Then I did the same with the core plugins, and still no linkable item found.

I don’t know whether doing that would have exposed the missing plugin issue you mention. Do you recall what plugin it was that the other person was using?

I have the feeling that this has never quite worked for me (and I’ve been using Hook for several years). Certainly I know I’ve sometimes had to use Obsidian’s ‘Reveal in Finder’ command and hook to the file that way.

The other thing is ‘Hook to New’. I saw a mention recently that that is supported with Obsidian, as in ‘Hook to New Obsidian File’? I don’t have that ability either. I don’t know whether that’s related, though.

At this point I’m wondering whether uninstalling and reinstalling Hookmark would help, but what would I lose if I did that?

In case of Obsidian, the supported features depend on what URL scheme you are using. We have a table here that breaks down features x URL scheme: Using Hook with Obsidian – Hook. You are using default scheme so Hook to New should be available to you.

Could you please verify in Hookmark > Preferences > Scripts Tab – Hookmark that you have not overridden the Obsidian script.

Other possible reasons are listed in No Linkable Item in … – Hookmark.

One way or another, that’s fixed it! I looked at the Scripts tab, and hit the ‘Reset to Default’ button, and now both things work.

I don’t recall deliberately changing that script, but maybe I tried something once? Who knows, but it all seems good now.

Many thanks

1 Like