No linkable item found in MindNode

I can’t seem to link MindNode mind maps from Hook and I’ve exhausted my troubleshooting ideas as well as those suggested on the “No Linkable Item In…” page.

I don’t if this is the source of the issue, but when I go to System Preferences → Security & Privacy → Privacy → Automation → Hook, MindNode isn’t listed as one of the apps that I’ve given permission to. Usually when I try to hook something in an app I’ve never done this with, I’ll be nudged by the system to give Hook permission. This isn’t happening with MindNode.

Furthermore, when I go to Hook → Preferences → Scripts, MindNode is greyed out, but I’m not sure why. (And, at that, it’s the only app that’s greyed out from the list of scripts.)

Any suggestions on how to make MindNode work with Hook would be very welcome—thanks!

If the script is greyed out, it means this is the script added by the user. You can send us the script and we can have a look.

Currently Hook does not have a specific script for Mindnode. It is supported by “Hook Default” script. Currently it can only hook to MindNode file. If you like using Hook Default script, you can save your MindNode scripts and delete MindNode from Script list. Then give it a try.

Thank you

Thanks for your response. That’s interesting—I didn’t add a script for MindNode. However, I deleted the greyed out one to use the Hook Default script instead, but when I try to link to the MindNode file (only the file, not a “node” or anything else), it still says “No linkable item found in MindNode” and I can’t hook to it. Any other ideas?

Have you tried restarting Hook?

If it still does not work, could you please run the following script in Script Editor and send us the result.
Also, your MindNode version, Hook version and macOs version.

tell application "MindNode"
end tell

tell application "System Events" to tell (process 1 whose frontmost is true) to value of attribute "AXDocument" of window 1

Thank you

restarting Hook solved the problem. Thanks @bchend