No linkable item found in Contacts [solution: Ventura 13.1 beta 4 fixes their AppleScript issue]

Getting this message after migrating to a new mac. For clarity, I get this message when I invoke Hookmark in Apple Contacts with a contact selected. On my other mac I’m able to then hook to that contact.

anything here help:


Thanks–tried all of those, but still getting no linkable item.

Is the contact in its own window or in a list view?

Is there anything special about the contact software-wise, e.g., involving third party integration?

I am having the same issue. I am using Ventura and the latest version of Hook (which I love). But, I am not able to “hook” to any contacts in Apple Contacts.

Let me know if there’s any additional info you need to help track down the issue.


Hookmarks is showing as not on the auth list in system settings (Ventura). Not clear how to trigger a re-request on Contacts authorization from Hookmarks.

Note that Applescript (in general) under Ventura has the same issue (unable to access Contacts).

Note that I tried resetting the Hookmarks AddressBook approval:

tccutil reset AddressBook com.cogsciapps.hook

but this did not trigger a reauthorization request.

Welcome to the Hookmark Forum , @ethanschoonover. Sorry for the delay in responding to this topic which fell off my radar after I first looked into it. We have confirmed there is a bug in Ventura affecting Contacts as you mentioned. Apple today released a second beta of 13.1 but release notes don’t mention Contacts AppleScript. however, their notes are often very sparse. We’ll try that build and report back here.

As a workaround it is possible to search in Hookmark. We will attempt a different workaround.

Thanks @LucB . I can confirm after upgrading the 13.1 release that the issue remains (no linkable items, AppleScript Script Editor showing same permissions issue as well).

1 Like

we looked into Shortcuts as a workaround but Apple’s Shortcuts action dictionary for Contacts is limited.

Your Contacts hookmarks (bookmarks) are not lost, however. You can still use Hookmark to search for the contact by name, and from there you can use the ‘focus’ command (right arrow) to access all the hooks associated with the bookmark.

It being a known issue with Ventura Contacts, and Apple having expressed its commitment to maintaining AppleScript, I’m confident they will sort it out. More on this later.

Thanks for looking into this. Always helpful to know it’s not a problem specific to my setup. I also appreciate @LucB’s point that the search and focus functions within Hookmark preserve all prior work even in the unlikely event that Apple never fixes this issue.

1 Like

I updated to beta 3, released 2d ago. Same problem. We have a ticket we can use with Apple on it.

Ventura 13.1 beta 4 seems to have fixed the Contacts AppleScript issue. Hookmark is fine in my tests.

1 Like

Confirming that Contacts link functionality fully restored in 13.1. Thanks!

1 Like

AppleScript access to Contacts now work again in my Ventura 13.1, it feels great

1 Like