Linking a folder to an OmniFocus item

I’m trying to link a folder in Finder to a folder in OmniFocus but am running into issues.

My current process:

  1. Select and copy the link of the item in OmniFocus
  2. Locate folder I want to link to in the – left-click to select it
  3. Invoke keyboard shortcut
  4. Press ⌘V or choose “Hook to Copied Link”

Everything seems to work fine at first glance, but when I tried opening the OF project from the Hook window after selecting the linked folder in Finder, it wouldn’t work.

Upon closer inspection, the link in Hook has a “%0A” appended to it. The original link from OmniFocus does not have that “%0A” text. I’m guessing it’s the line break that OmniFocus copies for some reason (a bug I guess on OF’s end?).

Raw OmniFocus link:
original url from OmniFocus

URL stored in Hook app:

Anyway, is there any way to remove this or fix it somehow on Hook’s end? Does anyone else run into this issue? If so, how have you dealt with it?

The Finder side of this should be irrelevant. To isolate the issue, you can paste the OmniFocus:// URL and use it anywhere. I’ve tried copying a link to an OmniFocus folder and it was fine. I also tried with your procedure.

I tried with OmniFocus Pro for Mac 3.11.7 (v149.14.0) and could not replicate the issue. Here are some example URLs:


If you use OmniFocus itself to get a URL to that item, do you get %0A tacked onto the end? Oh, …, I see that you have a screenshot which is presumably using OmniFocus’s in app Copy Link?

Do you have a new clipboard utility that might be messing with the clipboard?

Ever since I can remember I’ve always had that line break when I copied OF item’s links via OF’s “Copy as Link” function. So it could be something my system specifically is doing to the link. I use as a clipboard manager, but nothing else that I think would mess up the link.

So, you’re saying that when you copy an OF item’s link by right-clicking said item in OF and selecting “Copy as Link”, you get a link that doesn’t have a line break at the end?

That’s correct. Never seen it. I would try turning off to see if it makes a difference. If it does, you might want to verify its settings – maybe there’s a way to turn it off dynamically in selected apps/contexts; or ask them about it. If it’s not that, maybe the The Omni Group/forum have an idea, or someone here as we have a lot of OmniFocus users.

Do you still get the issue with SHIFT+CMD+V in step 4?

That’s super weird you’re not seeing it on your end, as OF support just got back to me saying it was a known bug:


Yep, same result unfortunately. :confused:

Ah, I see what is happening.

You used OmniFocus to copy the link.

I must have used Hook’s Copy Link, or I was looking for an escape character that I didn’t see. Either way, I have replicated OmniFocus Copy as Link issue.

Hook avoids the OmniFocus bug because its “Get Address” script uses AppleScript and constructs the link itself, like this:

        if class of theSelection is folder then
            set theURI to "omnifocus:///folder/" & id of theSelection
            set theURI to "omnifocus:///task/" & id of theSelection
        end if

So, Hook constructs the URL from the ID. We don’t ask for the URL, we construct it.

So the solution for you is to rely on Hook’s Copy Link not OmniFocus’s. So another advantage of Hook over Keyboard Maestro (UI scripted) style solutions for hyperlinking.


Thank you, that fixed it! :tada:

1 Like