Installed on Mojave, only to see beachball at the menu bar

I am new to Hook, wanted to work on the trial. However, after I installed (and given all the security permission, etc), it would not launch. I only see beach ball when the mouse hovers the hook icon at the menu bar. Uninstall and reinstalled multiple time after reboot and still no luck. Interestingly I cannot find it on the force quit menu.

The system is on Mojave (10.14.6) with 32 GB of RAM

Any help appreciated

welcome to the Hook Productivity Forum, @thirstylizard. And sorry that your first experience was a beach ball.

Have you disabled SIP (System Integrity Protection) per chance? if that does not ring a bell, then likely you have not.

Could you please take a sample of the process , store it in a file, compress it, and send it to me as a PIM or email it to ?

Here are instructions from an august Mac dev, The Omni Group Taking a sample in macOS - Support - :

what does it mean to sample a process in … - Apple Community

You should not need to uninstall / reinstall the Hook app itself.

Hook is currently a “background app”. Background apps don’t appear there, nor in macOS application switcher. We are discussing internally whether to give users the option to make Hook a foreground app. And it may evolve that way due to other features we would like to build into Hook.

Hi again, I’m writing to see whether this issue has gone away.

Best regards,

CogSci Apps Corp.

Hi Luc,

sorry for not replying early. I managed to install Hook on another Mac and it work. The first Mac I tried to install Hook did have SIP turned off , it is a Hackintosh, so it is a bit more complicated to turn it back on. Admitted, Hook is the first App I encountered that requires SIP to be ON. Anyhow, I am trying out the use case for Hook as compared to other apps.

Appreciate the follow up



1 Like

Thanks for letting me know – much appreciated. I’m delighted the issue is resolved.

Best regards,