Incorrect Fantastical 3 Links

Using Fantastical 3 and Hook 1.5.1 on Mac Catalina. When creating date links from Fantastical 3, Hook produces a link in this format x-fantastical2://show/mini/MM/dd/yy rather than what the URL specification seems to require which is: x-fantastical3://show/calendar/yyyy-MM-dd. See here.
Please advise.
Thank you.

Thanks for putting that on our radar, @jcromwell. And welcome to the Hook Productivity Forum.

Hook currently has x-fantastical2 scripts. We will look into fantastical3.

1 Like

If someone upgrades v2 to v3 in place, the installer doesn’t change the name of the app package from “Fantasical 2” to “Fantastical 3”. Probably the best thing to do is have the script check the version in the info.plist file inside the app package, and branch to either Fantastical 2 or Fantastical 3 URL syntax, depending on the result.


1 Like

We’ve updated Hook’s integration scripts (Version 116) to also support the latest Fantastical version. Check for App Updates and Update Scripts downloads and installs the latest scripts.

Please let us know if this doesn’t fix the issue for you.

@LucB, thanks for addressing this.
Unfortunately, when I use the Check for App Updates and Update Scripts feature, it says my software is up-to-date and there is no change in Fantastical link behavior.
Any suggestions?

Not working here with Fantastical 3 either.

(The legend is “No linkable item found in System Events”)

Screenshot 2020-04-22 at 17.14.04

Screenshot 2020-04-22 at 17.13.16

Better this time, but still no link:

(macOS 10.14.6) Mojave

Screenshot 2020-04-22 at 17.18.21

Sorry this is not working on your side, John.

Are you trying to link to Fantastical events or dates? Only dates are supported per the Linkable Mac Apps – Hook page:

√ (Hook can link to its dates but not events due to the Fantastical UI.)

By this we mean that we couldn’t get the info via UI scripting at the time we implemented this. their AppleScript dictionary is rather sparse so we use UI scripting. (I’ll get in touch with the dev.)

our internal notes on this from Nov 2019:

Fantastical doesn’t have anyway to get an address or identifier for an event, and doesn’t have a way to “show” events with applescript or x-callback-url, only dates.

as for date testing, here’s my own latest test on 10.15.5 beta

Using Hook scripts bundle 116 (In Hook > Preferences > Scripts tab , the version is listed at the bottom), I tested and got this:

  • Invoked Hook window on April 17,
  • select Copy Markdown Link,
  • paste it in a .txt file: Fri, 2020 Apr 17
  • switch to April 22.
  • activate the link above
  • fantastical opens / shows April 17.


  • created a file
  • Copy Markdown Link , yields forum topic 1426 test.txt
  • picked another date in fant…
  • Hook to Copied Link
  • invoke Hook on either side of the hook, and see the other side, and can navigate

We’ll have another look through the Fantastical app to see if there’s something we’re missing or something else that may have changed.

I’ll get in touch with flexibits to request AppleScript support. It doesn’t hurt to have other requests:

thanks for trying that out, Rob.
I see “no linkable item found in Fantastical” when I select an event (on bottom left) rather than a date. I’ve mentioned to our fantastical integration dev your System Events reference.

I get that it will only sync to a date, but even that isn’t working for me. Look at the link below:

I believe the link would work were it in “…/calendar/2020-04-20” format, per the Fantastical 3 url spec, rather than “…calendar/ 4/20/20” (and the problem isn’t just a function that the day and year are both 20), but maybe this is due to a setting on my machine?? What are other people seeing when they view the Fantastical 3 link?

however, I’ve managed to reproduce “No linkable item found in Fantastical” on two occasions. After switching from year to month view, and back again, I couldn’t reproduce the issue; but still that gives me something to work with.

Bi Ling here wrote:

> It only works when Edit -> Copy Day as Text is enabled. Sometimes, however, it is not enabled. I haven’t been able to figure that out yet.
> accidentally double click on the date, and it tried to add an event. After that, Copy Day as Text is disabled. Then I click around, somehow, it comes back.
neither she nor I are regular Fantastical users. however’ we’ll dig into it soon.

OK, problem solved for me. Seeing your image with the url in yyyy-mm-dd format sent me into my Fantastical preferences, where I then changed the short date setting to that format instead of mm/dd/yy.
Now the link works as you outline

1 Like

I’ve sent Flexibits another request an API for getting the name and address of dates and events. I originally made the request for this to them in 2017-10, which was about 15 months before Hook public beta. We had an exchange with their support over email. Their customer support was quite helpful; however, the feature hasn’t made it into Fantastical. Flexibits, if you are reading this, the email link for our original exchange is [Re: \[#FFJ-53366-341\] Flexibits: Contact Us](hook://email/ and thanks for considering it.)

Several third party devs have added APIs for linking in response to Hook. In fact, there is a developer of a related app who will announce their API support for linking in 2-3 weeks :slight_smile: .

Thanks, this was the solution I needed. This was not at all obvious and there may be reasons people need the system short date setting different to this. Is there a way in the Hook script to force the date format required by Fantastical or just manually form the string with separate day number, month number and year number?

1 Like