iCloud Sync problems

I’ve moved to SetApp on two macs, and updated to Hookmark V5.0.1 (5327) on both of them, running under SetApp.
Both Macs are running Ventura 13.1

iCloud Sync between them for the links I create is not working. When I do a search within Hookmark on one mac it says I have 174 links, but on the other mac it says 140.

I’ve tried deactivating, reactivating. I’ve tried logging out of icloud and back in. I’ve checked all the boxes I should check as given in the guidance.

So now I’m baffled. Anyone any suggestions of how to diagnose the problem?

I am wondering whether my migration from my previous hookmark to setapp and the move to V5 has upset things.

Thanks for any tips.

Sorry for the trouble.

Do you run Hookmark on both macs before you install Hookmark setup version on them?

Did you turn on iCloud sync for both macs before? If yes, did sync work fine?

Thank you!

I believe the sequence of events was:

Hookmark V4 on first Mac
Hookmark V4 on second Mac - sync successful after turning on iCloud Sync.
Hookmark V4 changed to Setapp version on first Mac and transferred links database across to retain links
Hookmark V4 changed to Setapp version on second Mac. But I can’t remember or be sure that I tested the sync at this stage.
Upgraded to V5 setapp version on both Macs
Sync tested and not working

I may well have messed up or corrupted something along the way.

I suspect the 174 links on first Mac’s hookmark would cover the 140 links on the second Mac - I don’t use the second Mac so often.

So it may be easier to simply delete the second Mac version altogether and the database and start afresh there. If I did that sort of reset, would the 174 links sync across to the second Mac.

Is there a good way to delete and do a complete fresh install on the second Mac? Are there hidden files I should delete?
I use Hazel and that will clean out files when I delete an App - is that a good way to go?

Thanks for your help, no need to apologise, I’m sure it’s my set up process that’s messed it up.

Thank you, @grahook.

You can rename the following folder(just in case):
/Users/YOURUSERNAME/Library/Application Support/com.cogsciapps.hook-setapp to something like
/Users/YOURUSERNAME/Library/Application Support/com.cogsciapps.hook-setapp.old

You can go to that folder via Finder’s menu Go->Go to Folder…

Then restart Hookmark, it is a fresh start.

Thanks, done, and sync seems to be working fine now.