How to hook items in QSpace Pro

QSpace Pro is my main file manager, which is robust enough for me and as simple as Finder. It’s so sad that it’s not supported by Hook now. I do hope the developers can take this application into account, and I wonder whether there is plan to make Hook able to integrate with it.

Apps with basic AppleScript support are often supported out of the box, or with minimal effort we can often create a script. Can you ask the developer whether it has an AppleScript and what it is? x-callback-url or other APIs for linking are also fine. Cf Contacting Developers of Other Apps and Information for Developers – Hook

Thank you for your early reply! I’ll try to ask their developers about this and tell you about their responses later. I do hope this problem can be solved! I have got so accustomed to using QSpace that it’s now nearly impossible for me to switch back to Finder or other file managers, as Finder is not as robust while other file managers, like Path Finder that Hook currently supports, can be a little bit complex for me.

1 Like

I have asked the developer of QSpace, and their response is that they will support AppleScript in the next version and hopefully it will be released in a month. Although I’m actually technologically illiterate, I’m so happy that this problem can be solved soon! Thank you for your kind support!

1 Like

After almost a month the developers of QSpace finally respond! They launched a new version the other day, which supports some Apple Script now. So I wonder whether it is possible to integrate Hook with it now~

1 Like

Thanks for that @uu2003. We tried the following script and ran into an error

tell application "QSpace Pro"
	set s to item 1 of selected items
	get name of s
	get URL of s
end tell

error "QSpace Pro got an error: Invalid key form." number -10002 from selected item id "/Users/test1/Downloads"

I couldn’t find their contact email. If you could share it that would be appreciated. Alternatively, they can join the discussion here if you would direct them to it.
Thank you.

1 Like

Thank you for your early reply. I can contact their developers to see what’s going wrong~

This is their contact email: I’ll also ask them about this question in the group chat.

1 Like

The developers of QSpace tell me to add this script in Get Adress and that’ll be OK. But this is not the case for me, there’s still no linkable items found in QSpace. And till now they still don’t respond to me, I feel a little bit weird now.

tell application “QSpace Pro”
set theItems to selected items
set n to count of theItems
if n = 1 then
set ext to name extension of item 1 of theItems
if ext = “hook” or ext = “HOOK” then
set filepath to item 1 of theItems as alias
return read POSIX path of filepath
end if
end try

	URL of selected item 1
	URL of root item
end if

end tell

I try to delete the script and re-add it to Hook, and it works for QSpace now! I’m so happy~ Thank you for your kind support all the time~

1 Like

super! we look forward to testing it and updating Hook. Thanks very much for doing this liaison work with the QSpace dev. Much appreciated! Basically, for every app we’d love to have liaisons to the app’s software community and dev. At CogSci Apps Corp., we do a lot of direct B2B communication with devs, but it’s great to have community-to-community , community to dev, communications.

Hi there!

I’ve been trying to copy the code above into the relevant Scripts section, but still getting the “No Linkable Items” tag in Hookmark. Any suggestions?