Hookmark 5 hangs on "updating info of bookmarked files..."

macOS 12.6.2.
What I’ve tried: Several restarts of the app, of the OS; re-downloaded app from hookproductivity.com and installed again – all to no avail. App hangs at what looks like exactly the same place in the progress bar, offers an ‘OK’ button but silently fails; Hookmark is not functional after being oked, and needs force-quittin via task manager. Any ideas? Thanks for looking into this.

1 Like

Thanks for letting us know, @kithairon.

Could you please capture the process using How to Take a Process Sample of Hook with Activity Monitor app – Hook, compress it, and send it to us support@cogsciapps.com?

Then please force quit the app using Activity Monitor. it should be fine.

We will look into the crash report.

thank you,

1 Like

I’m having the same issue with Hookmark v5.0 and I’m also on macOS 12.6.2

Sorry for the trouble. May I ask how long did you wait for “Updating info of bookmarked file…” before you click on the OK button? It might take a while for Hookmark to finish updating the database.

Thank you

On several counts I’ve waited longer and longer. The last time it was close to two hours.

Sorry please ignore my message about 12.6. I thought you meant 10.12. I read that way too fast. @bchend will continue on the thread.

Sorry for getting back to you late. We have been trying to reproduce the problem on our side but no luck yet.

First, could you please let us know
(1)How many bookmarks you have, if you can remember?
(2)How many files under folder:/Users/YOURUSERNAME/Library/Application\ Support/com.cogsciapps.hook/com.cogsciapps.hook/aliases? You can go to that folder via Finder ->Go ->Go to Folder…
(3)Do you have external drives or network drives?

Also, could you please give the following a try?
Could you please go to folder: /Users/YOURUSERNAME/Library/Application\ Support/com.cogsciapps.hook/com.cogsciapps.hook and delete 1.1 and 1.2 files. Restart Hookmark and see if it helps.

If the above does not work, if you have turn sync on, please run the following command on Terminal:
defaults delete com.cogsciapps.hook preference.sync.method

Also running the following command to turn “Show current item’s number of hooks in menu bar icon” off(if it is on, you can always turn it back on in Hookmark’s preferences window)
defaults delete com.cogsciapps.hook menubar.icon.status

Restart Hookmark and see if it helps

Thank you

1 Like

Thanks for getting back. I miss Hookmarks badly! Followed all of your suggestions, still no luck.
Re your questions:
• Bookmarks: I may have a a few hundred bookmarks.
• Under /Users/YOURUSERNAME/Library/Application\Support/com.cogsciapps.hook/com.cogsciapps.hook/aliases if have counted 1690 aliases.
• I have deleted the 1.1 and 1.2 file in /Users/YOURUSERNAME/Library/Application\ Support/com.cogsciapps.hook/com.cogsciapps.hook
After that the message on the screenshot attached appeared. The process seems stuck again, though much further on the progress bar than before deleting the files. I’ve let it run for 30 minutes before pressing the ok button.
• External drives and network drives: I have a NAS running – mostly backup and media. The only documents relevant to Hookmark connected with my NAS are Obsidian files that are synced to a folder on the NAS. (Most of my Hookmarks are from Obsidian to Zotero and Obsidian to other stuff on my HD. Nothing else on the NAS is hooked). My Hookmark Folder (with templates etc) is stored locally.
• Have run the two Terminal commands. Any more options?

1 Like

Thanks for persisting, @kithairon . Could you please try this from Terminal app

defaults write com.cogsciapps.hook hfile.url.search.scope user

then hit return key.

that will cause Hookmark to ignore the NAS for now, per Preferences Accessible from the Command-line – Hookmark.

1 Like

Re: restriced the scope to “user” with running
defaults write com.cogsciapps.hook hfile.url.search.scope user
from the commandline. Unfortunately no luck. Still hangs on “Updating database to 1.1”.
Do you have more ideas?

thanks, @kithairon. Will follow up via a PM for console log info (best not to share log info on public forum).

Fine. Will be offline shortly for a night’s sleep :slight_smile:

We have a fix that we will share with @kithairon . If that checks out, we will publish it first as a beta that all can download, then as 5.0.1 per se. If someone else also encounters the issue please PM us via “Message to support” button above.

1 Like

same problem here. Tried to run HookMark today, first time it displayed the dialog “Hookmark is initializing…” for about 6 hours until I force quitted Hookmark via Acitivity monitor. Tried to start it again but same result (no network drives, iCloud is synchronized). Environment similar to the one described by @kithairon

Same thing here. Same symptoms, same system (Monterey). Hookmark version is the latest.

Something changed, don’t know what, but now, on launch, Hookmark stays stuck on the updating info of bookmarked files window for 10 to 12 seconds then the window closes and Hookmark resumes normal operations.

Sorry about this issue.

Does it happen after you updated to Hookmark 6? How long does it take before?

Thank you

Does it happen after you updated to Hookmark 6?

No, it did not happen – just – after the update, but maybe because I did not reboot my laptop for a long time and it may have appeared after the first reboot after the update.

How long does it take before?

Oh, before it just hanged. I mean, this morning I found Hookmark non responsive and the updating info window just sitting behind other windows for I don’t know how much time. Then I force quitted Hookmark, rebooted and it again got stuck on launch, and stayed like that until I force quitted it again.

But now everything seems back to normal. I will check if it stucks on my next reboot.