Hook to New nvUltra does nothing

Hi! I’m finally investing some effort everyday to incorporate Hook into my workflows and it looks very addictive.

I want to use nvUltra as my main personal info management repository, so when I Hook to New, nvUltra is set to be the default app to respond.

With that said, nothing useful happens when I summon Hook to New => nvUltra:

  1. Hook disappears,
  2. no note is created in nvUltra,
  3. and if I summon Hook on the original item again, no link is shown as having been made.

I tried:

  • Hooking various things and it doesn’t help.
  • Hook to New => Drafts and it works as expected.

I use the latest versions of Hook (1.8 3439, scripts 121) and nvUltra (1 beta 65).

Thanks for any help!

Thanks for raising this, and for emailing us the extra info, @danieljomphe.

A dev here is looking into it.

One issue with the current nvUltra integration script is that it assumes that the user has configured Hook’s default notes folder.

But the bigger issue may be that it cares about this folder at all. I think that should (by default) be irrelevant to the nvUltra case, because nvUltra has its own default notes folder.

However, there may be some other assumptions in the script, which we’re looking into.

But for now to get around the issue you might simply configure your default notes folder. You might also want to make sure that you’ve created a note in nvUltra such that it has its own notion of notes folder setup. But if that doesn’t work, please bare with us as we look into it. Basically, our doing tests from a default account with no configurations reveals the issues that you’ve run into.

Version 130 of Hook’s integration scripts contains an update for nvUltra.
We took out references to Hook’s Notes folder from the script. We also added an error message in case nvUltra can’t create the note for some reason.

Please let us know if this works for you.

For those who do not know: nvUltra is a note-taking app from Brett Terpstra and Fletcher Penney: “Searchable, portable, MultiMarkdown notes”. It’s currently in private beta, but users can sign up for updates as development finishes up. Version 1.0 is due very soon. I’ve been using daily since the private beta started and have been very impressed with.

While the scripts v130 become available (I can’t get to them, my Hook scripts stay at 121 for now), I tried setting Hook’s default notes folder, but it was already set up to .../Hook/notes, an empty folder. That’s something I had already double-checked existed. But this time, I clicked on the folder icon to the right of the field, and selected the same folder and clicked Ok. Guess what, this seems to have created the missing plist property required for the script v121 to work!

I can now create nvUltra notes. I can get back to testing Hook and nvUltra together! :confetti_ball:

Thanks for the help, Luc and team!

1 Like