Hook links from Devonthink to Craft fails for emails

Since yesterday I notice that I cannot link items from Devonthink (just for imported emails!) to craft with the simple copy/paste procedure as I am used to. It works fine for all other file types I have tested.
Pasting the link in Craft results in an “empty file” error (s. screenshot1). However, when I create a Hyperlink to a specific word in Craft (s. screenshot2) with the same copied link, the Hook works. Please fix this bug. Thanks!

With the update you released today, this problem has been fixed. Thank you!

1 Like

We didn’t change anything, so it had nothing to do with Hook :slight_smile:

Anyway: on my MacBook and iMac (both M1-driven) I still cannot hook links from Devonthink (interestingly only email-type) directly to Craft. However, I can past the hook-generated email-link from my cache manually to add a link to text in Craft.
Interestingly, for files and folders I still can paste a hook from DT to Craft as I am used to. The problem exists only for emails archived in Devonthink that I want to link to Craft.


could you please provide a step-by-step explanation of what you mean by that, preferably with screenshots. Also a comparison of the same workflow from DEVONthink and another app (e.g., TextEdit) with screenshots would also help. Thank you.

I recorded a short video of my problem. You can download the video here.

Hi - any news on this? The problem remains even with the new Hookmark and the newest versions in Craft and Devonthink.
Thanks for an update.

Sorry, Luc had looked at it but I will have a look . Can you pls share it again?

it meaning the video.

You can access the video now again. Looking forward to your response. Thanks

Any news here? Can you access and watch my movie?

Sorry for the trouble.

I did see the problem you described once. Then I tried Hookmark markdown link(command+M) and Craft accepts the link.

The strange thing is, after the success of that markdown link, Craft will also accept links from Hookmark’s “Copy Link”.

Could you please give it a try?

Thank you!

Inserting a markdown link is a good workaround and worked for me. However, it’s odd. The second step that Craft would accept links from a copy link didn’t work in my case.
Are you planning the fix this?