Hook and Goodtask Compatibility

Goodtask no longer seems to allow Hook to link tasks. While I read on the Hook website this compatibility did exist at one point, did something change? Is it something that can be re-enabled?



Welcome to the Hook Productivity Forum , @jtanzer14 . Thanks for asking.

Our Linkable Mac Apps – Hook page says

Last time we checked, GoodTask did not have an API to get the ID of calendar events.

According to your screenshot, you seem to have selected a calendar event.

Hi @LucB thank you for the response (and development of this app, which I love!). I think the view I shared was of the task page. Here is another that splits out Tasks from Calendar events - I am trying to hook the task.

Thanks @jtanzer14 .

The item in your screnshot shows a date/time range of Sat, April 9, 5:00 AM ~ Tomorrow, 12:00 PM. That suggests it is a calendar event, not a reminder…

Surprisingly, in the Today view (SetApp version of GoodTask) I also see some calendar events, and Hook does see their title, so that [unexpectedly] works in my test.

I wonder if the difference is the type of calendar… I’m not very familiar with GoodTask. Does it work with other calendar services beyond icloud? If so, might that be a relevant difference?

Can you please use Hook’s search tool to find a previous GT calendar event, open it, and then invoke Hook on it? I.e., is this affecting previously hooked items, or not?

BTW, Hook uses GoodTask’s x-callback-url. It’s a pretty simple integration script…

My testing today is with GoodTask 7.0 (983).

Hi @LucB thanks again for digging into this. The dates shown reflect the due date and a reminder date, it’s not a calendar event. I just created a task with no associated dates and it doesn’t seem to hook.

FWIW, I am on Monterrey, Goodtask Version 6.9.5 and Hook Version 3.4.3

I hate to recommend a sledgehammer, which you have probably tried, but just in case: relaunching each app, and possibly even macOS?

Or these tips if you haven’t tried them: No Linkable Item in … – Hook? Is it possible your permissions for the app were inadvertently changed. Before macOS 12, macOS occasionally had strange permission issues. Maybe those issues persist? I hope not.

2022-04-15 14:31 (PDT): updated tips paragraph above.