Freeze with fantastical [resolution: keyboard shortcut conflict]

Hi, just testing out this fascinating app. One issue I’ve found is that when I try and use Hook with Fantastical, Hook freezes 9 times out of 10. It can’t be invoked and clicking in the menu bar doesn’t do anything. Eventually I see Not Responding in Activity Monitor and have to kill it. It does occasionally work though.

For some reason, it also stops Keyboard Maestro from responding. When I kill Hook, KM starts responding again. I thought that maybe KM was interfering with Hook, but if I uninstall KM entirely the issue with Hook/Fantastical continues to occur. I’ve had no other issue with any file or app I’ve tried, it either works or just says it can’t find a link.

I can see from earlier posts that Fantastical doesn’t have true support, as it were, so is this just a limitation of Hook with Fantastical at the mo? Or a bug?

Running macOS 11.0.1, fantastical on 3.3 and Hook 2.0.3.

Many thanks

Welcome to the Hook Productivity Forum , @bishblaize, and thanks for letting us know.

We’ve had a customer also using Big Sur report a freeze with Drafts App and keyboard-driven Hook window . However, under Big Sur (official release), he had problems in many other apps, so it was not a Hook issue per se.

He was able to fix the problem by doing the following.

  1. Go to System Preference Security & Privacy > Accessibility
  2. Uncheck Hook
  3. Remove all Hook apps on his machine. (In accessibility, right click on
    Hook > Show in Finder, repeat until Hook disappear from Accessibility list)
  4. Restart machine
  5. Download and re-install Hook

There are reports and we may have seen that macOS can get confused with Accessibility permissions. There are more drastic means involving
~/Library/Application\ Support/, but they require disabling System Integrity Protection which is not something we would normally recommend.

In the context of Drafts on Big Sur, we have seen a lag in presentation of Hook’s contextual window; but only when accessed via menu bar window.

In any event, this seems to be to be a Big Sur issue (as Drafts works fine for us in prior macOS versions). I will install the latest Big Sur Beta update asap to see if it’s resolved there. (I don’t recommend customers install macOS betas just for any issue Hook might have with it).

It might not be a coincidence that linking in Drafts and Fantastical both currently require UI scripting. Perhaps (?) there are issue with UI scripting and Big Sur. If so, Keyboard Maestro forum would be discussing them (I’m catching up there).

Sadly that didn’t work for me, I still get a freeze. No matter, I’ll keep an eye out for future updates.


Thanks for letting us know, @bishblaize. Is this happening on a M1 Mac?

I wish. I’m actually on an intel based hackintosh.

Big Sur on that could be “interesting”. Have you experienced problems with other apps? It may be worth looking into general Big Sur issues , and some particular to your environment. E.g., macOS 11 Big Sur problems: how to fix the most common issues | TechRadar.

No, no other problems at all.

1 Like

@LucB Quick update on this, I think I got to the bottom of it. I noticed from the Apple Script entry for Fantastical that it presses Command+Shift+C to copy details of the current calendar entry. That’s also the shortcut I had set for the global copy command in Hook (which I think is the default?). I’m guessing every time it reached the point in the script where it was supposed to copy the calendar entry it just triggered itself again, reached the same point, triggered itself again etc and eventually hanged.

Disabling the global shortcut or changing the keyboard shortcut solved the problem. Works great now. Cheers.

1 Like

Thanks for letting us know!

That’s yet another reason why many in the automation community wish app developers would provide a modicum of automation for their apps. UI scripting is bound to language and all kinds of idiosyncrasies.

Delighted this is resolved.

1 Like