[fixed with 3.0 compiled universal/ M1+intel] Preview.app not working [for some M1, Big Sur customers]

Despite Preview being listed as a supported app, and despite me giving Hook Automation privileges with respect to Preview, when I invoke Hook with an open PDF I get “No linkable item found in Hook”. Any idea what’s up?

1 Like

Have you tried everything in No Linkable Item in … – Hook?

does this happen in all folders?
What macOS?
Tried in a different macOS account on the same Mac?

Tried a reboot?

Hi Luc, I’m running 11.2.2. Rebooting had no effect - Hook hangs for a while when I first try to invoke it with Preview, then eventually it pops up with no linkable item found. I don’t have a different macOS account set up to test it on but can do so if you’re unable to replicate. It doesn’t appear to be limited to one directory - tried this on Dropbox, iCloud, and my Downloads folder, all with the same results.

Interestingly, when I run each of the two Applescripts for Get Name and Get Address in Script Editor there’s no trouble at all. I’ve also tried unchecking and checking Preview from Hook’s Automation list in Security & Privacy preferences.

thanks for the extra info, @tedsvo .

Are the Preview problems with PDFs only, or images too?

Does Hook behave reliably well with other apps on your Mac? for example, if you select the same files in Finder, does Hook show up?

Hi Luc, happens with both PDFs and Images, and works fine in Finder (as well as other files in other apps). Recording here

Thanks, @tedsvo . Our team will re-dig into these issues. I suspect that there’s something going on with macOS 11’s app permissions, where permission is granted but then revoked or cannot be reset, or requires steps for resetting. A connection of mine in the macOS security space (not for Apple) suggested this.

I would need someone who has this issue to try it in a different macOS account to shed a bit of light on it.

I will return to the issue.

Hi Luc, thanks for this. I created a test account, launched Hook, and activated it in Preview, and the same issue happened - a beachball for what seems like a few minutes, followed by no linkable item found.

1 Like

thanks for letting us know, @tedsvo .

Seeing same situation on my MBP (new M1 running Big Sur 11.2.3).

Same problem related to preview on my MacBook Air M1 running newest Big Sur 11.2.3

+1 (MacBook Pro instead of Air)

This is extremely unlikely to be a Hook issue. We have seen that macOS 11 can sometimes get confused with respect to permissions.

We have seen that even if an app is listed in Automation, it may be necessary to toggle it off and on.

Please try this:

  1. Open System Preferences
  2. Click on the Security & Privacy button
  3. Click on the Privacy tab
  4. click on the Automation tab
  5. if the problematic app (here Preview) is not enabled, enable it.
  6. if the problematic app is enabled, try unchecking it, then checking the checkbox again.
  7. You may need to relaunch Hook in the app.

A reboot after changing Automation settings of an app may be required.

We have significantly updated the No Linkable Item in page, for one-stop shopping on the issue.

I think this is a problem with the m1. I have both an intel Mac mini and and M1 MacBook Air. Invoking Hook in Preview works in the former but not in the latter. I’ve checked everything that is mentioned in this post.
Also, notice the the M1 is the common thread.
Thanks for the great App, by the way. It has been very useful for my research although I fill I’ve just started learning how to use it.

1 Like

Are you running an old (2020) version of Timing? There was an issue where Timing would block AppleScript. Not specific to Hook, but Hook was collateral damage due to its use of AppleScript.

Welcome to the Hook Productivity Forum , @andresgm_org, and thanks for letting us know, and the kind words about Hook.

When No linkable item found in <App> happens for a supported app on M1/Big Sur, it’s almost always resolved to permissions issues. Either user declining the privileges accidentally, or Big Sur reverting permission for unknown reasons. Like I mentioned above, for the long delay case, we found an old version of Timing as being the source. This can be checked by running AppleScript directly from Script Editor, independently of Hook (potentially in a loop with some logging, if it’s an occasional problem.)

Hi Luc, no I don’t use Timing and I didn’t transfer any backup to this M1 MBP when I bought it, so it shouldn’t have other cruft from prior applications.

Still getting the beachball and No Linkable Item problems. I tried toggling Preview automation for Hook and restarting Hook to no avail. Perhaps I should try totally reinstalling Hook?


Same here; New installation from scratch on M1 MBP, no Timing never ever but same problem. Tried every solution suggested several times without any luck so far …

1 Like

Strictly with Preview app, @racemase ?

could someone who is having this issue search for “Hook” in /Applications/Utilities/Console.app , replicate the issue, save the file, compress it, and mail or PM it to us? (Please don’t paste it in the public forum however. There’s a Message to Support button at the top of this web page.)