Drafts integration - not listed in Automation in System Preferences

I am getting the no linkable item message when using Drafts. Hook works in other apps fine. Should there be a choice for Drafts in the Automation section of System Preferences? I do not have Drafts as a choice.

Thanks for any help / suggestions.

I installed Hook on a second MacBook I have and Drafts is listed as a choice under the Hook section of Automation. I also had a prompt for allowing Hook when I used in for the first time in Drafts.

I guess on my main MacBook for some reason missed the prompt or selected do not allow. Is there a way to be re-prompted or some other way to fix this so Hook can automate Drafts?

Thanks in advance for any help or suggestions.

Welcome to the Hook Productivity Forum , @smythg .

Have you tried No Linkable Item in … – Hook section " 2. Hook’s Automation permission to control the app is effectively disabled"

Or, due to an apparent bug in macOS, macOS may have ‘forgotten’, or failed to record, that you granted Hook permission to control a particular app. Or you may have revoked such permission.

You can grant, or re-grant, permissions as follows:

Thanks for the reply @LucB . I had looked at that info. The problem I have is that Drafts is not listed in the Automation section of Hook. So nothing for me to disable/enable. OmniFocus, Outlook and others are listed. But…

I have rebooted and Hook is now working with Drafts. :slight_smile: Checking the Automation area of Preferences there is still no Drafts listed. :confused:

So Drafts is working now, but would you expect it to, and so this is not really fixed and might stop working again.

Thanks again for your help.

If it stops working (which it probably won’t), you can try toggling the Hook checkbox there, possibly restarting , and launching Hook again. macOS should ask you for accessibility permissions at that point.

Hi @LucB ,

There is no entry for me to toggle for Drafts in the Automation section. Is this normal?

I ask in case this is masking some other problem I have, and I end up in a few weeks time having to start again with Hook and I loose all the hooks I have setup between now and then. At the moment I only have about 20, but can see this becoming 100’s over the coming weeks.

Thanks.

as noted, we have observed the “no entry in macOS preferences” in the past and it has never meant loss of access to hooks. Those hooks will continue to work. Your hooks will also be available via search and via other means (e.g., we will soon introduce a feature to feed a URL directly into Hook).

Thanks @LucB :slightly_smiling_face:

Looking forward to really getting into Hook now, particularly between Drafts, Outlook, Slack and Finder.

1 Like