[DONE, but investigating issue] Any possibilities for Ulysses integration?

Super. if you could send me the URL, PDF or title of the paper at some point that would be great.

I’m still active in sleep onset and insomnolence. We’ve had a paper accepted http://www.sfu.ca/~lpb/pubs.html with modifications @ Sleep Medicine Reviews . And wrote two new theoretical papers that we need to get published.

I’ve used Hook a LOT for my academic work in the last couple of years. It’s great to get it out into the wild!

Cool! Have a look at my Research Gate page; if there’s something there you can’t access, feel free to let me know.

We’re getting a lot of requests via email etc. for integration with Ulysses. For the sake of new users finding this post, I note again that Ulysses lacks requisite Applescript.

However, we have recently asked Ulysses’ developer for it using thee Ulysses Contact form. On Twitter they are: Ulysses (@ulyssesapp) | Twitter.

If Hook+Ulysses users would like the following tweet, it might help the Ulysses developer prioritize this: Hook: Mac productivity app on Twitter: “We’re getting a LOT of requests (via Hook’s forum and email) for Hook to work with @ulyssesapp as it does with many apps. It would need minimal AppleScript. Could you please provide some?” (links redacted ).

FYI Our integration tips for developers are here: Integration – Hook

(Hook works with many Markdown-enabled apps, such as Marked 2, MailMate, BBEdit, Bear and MultiMarkdown Composer).

Following on @AutonomyGaps’ original post. You might be able to work something using Ulysses’ x-callback-url support. You can have System Events press-hold ⌥ then press ^⌘C then press “Copy Callback URL” to get the ulysses:// URL for the current sheet (i.e., a “note”) in Ulysses.

1 Like

Thank you, we are on it. We should have something very soon.
The Ulysses team also kindly pointed us to their x-callback, which I hadn’t noticed.


FYI, if all goes well, we will release a build with Ulysses support on March 7 (Pacific time, as always).

Ulysses support is now included in Hook Version 1.0-beta (2155) - Releases - Hook Productivity Forum.

I have not personally checked this with the new version of Ulysses coming out of beta soon.

Brilliant! Thanks so much. Ulysses linking is working beautifully now. I’m running the Golden Master Beta for Ulysses 15.

No joy with Hook b2155 with Ulysses 14.4 on macOS 10.14.3

I gave Hook permission to control Hook when first prompted.

My bad, the latest release is actually build 2115.

Worked well yesterday. However, I noticed this the first time I tried to invoke Hook on a Ulysses document this morning. Subsequent attempts worked fine. In my case, it looks like it was a timing issue.

Could be, but I’ve been trying it for a while now and it continues to error out.

Just on the off chance I had done something wrong, I reset Ulysses and System Events in the privacy database. No luck.

I happen to be using the Setapp instance of Ulysses – same version; different bundle ID than the regular instance. It’s possible that’s a problem. You might want to use the “ULY3” app ID in your script, if you’re not already doing that.

Never mind – changing the ID in the script doesn’t make it work.

I’ve tried repeatedly for days to get the Hook-Ulysses integration working. I even reset the entire privacy database on this Mac – an action that takes a very long time to recover from – with no luck. The has to be something wrong with the script.

I wouldn’t consider this request “[DONE]”. Sorry. :frowning_face: Did anyone at Soulmen actually try this?

1 Like

Thanks for reporting and investigating this, @quorm. I’ve logged this bug report for tracking this issue: Ulysses integration not working for some users - Bug Reports - Hook Productivity Forum.

They acknowledged the integration in a Tweet, but have not indicated to me that they are using Hook. Now that there Beta is over, I assume/hope they’ll be able to look at Hook.

changing the title, but tracking it with a separate bug report will be easier (more focused) and Ulysses users will hopefully find it in the Bug Report section and hopefully contribute to the topic.

You’re terrific! Thanks.

1 Like

Ulysses 15 was released today.

Sad to say, the Hook integration doesn’t work for me in v15 either. :frowning:

Just to link if people looking here haven’t seen, I’ve posted a suggested addition to the built in handling here which may help with your issues: To invoke Hook window in Ulysses one needs to select the doc in the Sheets column (not put the focus in editor). A bug with Ulysses

I’m responding here @quorm re [FIXED] Ulysses - 1.2 - Error linking new document - Bug Reports - Hook Productivity Forum where you mentioned

I’m sorry this is still not working, and my apologies if I asked you this before, but do the Hook-Ulysses integration scripts work when you run them within Apple’s Script Editor?

@quorm if you could also please send us some Debug info that might help.

  1. launch /Applications/Utilities/Console.app
  2. type “Hook” in its search bar (top right)
  3. In its Action menu checkbox on both Includes …
  4. clear its log
  5. In Ulysses select a sheet
  6. Invoke Hook
  7. copy the Console’s output
  8. paste it in a .txt file
  9. delete any information from the file you don’t want to share with us.
  10. compress the file (via Finder)
  11. send it to us as a PIM or an email to support@cogsciapps.com ( you can also use hook@cogsciapps.com , but keep in mind those emails are routed through our Discourse instance as PIMs)

Thank you.