Did I Make A Big Mistake?

I had many existing Hook Links to an internal mechanical data drive that I wanted to replace with a new SSD.

I cloned that drive via super duper’s latest beta to an external SSD.

Now many Hook links to things like PDF files on that now removed internal drive don’t work.

Should I have simply MOVED those files to the external drive instead of cloning the whole drive to the new external SSD? So that Hook would have known to update those moved files links rather than cloning?

I think those links are now looking for that old drive’s paths etc.


1 Like

My understanding is that the links should just continue to work.

1 Like

macOS does not really support moving across drives (volumes) anyway.

Hook will be able to heal if the new files have the same name. If a given file bookmarked by Hook has a name that is shared by multiple files, hook will look for the best matching paths. If need be, try relaunching Hook.

Is there a way to force Hook to rescan all bookmarks in this situation to firm up connections before names may get changed?

For this situation, currently quitting and relaunching Hook is the best approach.

emphasized textWhat I did was actually rather complicated.

  1. I had my 2018 iMac 18,1 upgraded at a trustworthy local repair shop in Manhattan with a new SSD internal drive and I doubled the Ram to 16Gb.
  2. It originally came with a glacially slow 1 TB mechanical drive that could not handle any OS beyond Sierra (very, very slow).
  3. So, from the beginning I booted from an external SSD over one of the Thunderbolt ports and used the original internal drive as a Data Disk for things like my music library and my Dropbox folder as well as all kinds of other file archives.
  4. Prior to the upgrade I used Super Duper’s latest beta which they think works with Big Sur (11.5.1) to finally successfully clone to a bootable external drive. (So I could then Super Duper BACK to the new internal SSD (Samsung 870 1TB for plenty of space)
  5. I securely erased the internal mechanical drive AFTER I Super Duper that to another external Samsung SSD Drive.
  6. Upon returning from the shop I successfully Super Dupered back to the new Internal SSD. Diagnostics and other manual tests all passed.
  7. My new “Data Drive” external SSD also passed all diagnostics and seemed fine.

But as I said in my original post many Hook Links to things that were on that original internal Data Drive do not work at all. Clicking yields no reaction.

Now SOME of these may be related to using a Dropbox folder that was set to NOT store files locally but leave them online. (As files become needed Dropbox than downloads just that file to a fully functional local copy. This holds down on local storage requirements, obviously.)

But I noticed that several Hook Links that were NOT in the Dropbox folder were also no longer working.

So, I rebuilt the Spotlight Index entirely, twice. This did not help with either Dropbox “stored” files or other files that were originally on the 5,400 rpm internal “Data” drive.

I can view all 318 Hook Links (which I think is a correct number) via both Hooks Search facility AS WELL AS via the Hook “Browse Hook Bookmarks” Action the most up to date version of Launchbar.

But those that do not work from either of those search facilities (AND ALSO don’t work via NotePlan 3’s Hook Markdown links that I have collected laboriously to track projects over the last half a year or more) are ALSO not showing up when I search via Spotlight!

So I am painstakingly re-creating as many Hook Links as I can manually locate but this is a mess with many variables.

P.S. And I’m not even going anywhere near an older issue involving anything MOVED (but not originally CREATED) in Boxcryptor! (Which has been unable to make Spotlight work in Big Sur going on since Big Sur became available since what - last September?)

Luc thought these links would be healing over time and I’d hoped rebuilding Spotlight would help that but no joy yet.

TIA everybody.

Are you certain that the drive on which the files are now located is indexed by Spotlight? Does Spotlight find some of the files to which Hook URLs are supposed to point? Spotlight privacy settings are configured in macOS System preferences.

When files are copied to a new volume, Hook initially relies ​on Spotlight to resolve the URLs.

2021-08-08 14:39 to clarify the above, please

  1. Make sure the disk containing old files is not connected (to prevent collisions)
  2. Make sure the disk containing files you want to access is connected.
  3. Make sure Spotlight is turned on and indexing on the new disk is enabled.
  4. Restart Hook, wait some time for self-healing to take effect.

@mascotca if that doesn’t do the trick, let’s start a PM or email thread to get to the bottom of it, as we may need to ask about particular file names etc. That will keep the file details private and CSA will be able to more quickly respond based on notifications. We can then report back here about the resolution.

I rebuilt the spotlight index earlier today via the System Preferences panel for Spotlight (as mentioned) but I think it must have worked ONLY on the system drive.

After some internet research re: reindexing Spotlight on an external drive (Fixing no Spotlight results on macOS Big Sur | The caffeinated engineer) I found someone who stated that Big Sur had TURNED OFF Spotlight on drives by default!

So I followed his instructions for using Terminal to type in the following:

Last login: Sun Aug  8 18:37:51 on console
tempscott@Temps-iMac ~ % sudo mdutil -sa
	Indexing enabled. 
	Indexing enabled. 
/Volumes/New Ext INT DATA:
	Indexing and searching disabled.
	Indexing disabled.

Which seems to confirm that yes indeed indexing and searching are disabled on that external SSD drive I call “New Ext INT DATA”

I then went to his step 3 re: “BONUS: Enable indexing of external hard drives”

tempscott@Temps-iMac / % sudo defaults write /Library/Preferences/com.apple.SpotlightServer.plist ExternalVolumesIgnore -bool False
tempscott@Temps-iMac / % cd /Volumes/New\ Ext\ INT\ DATA 
tempscott@Temps-iMac New Ext INT DATA % ➜  Backups sudo mdutil -a -i on
zsh: command not found: ➜
tempscott@Temps-iMac New Ext INT DATA % sudo mdutil -a -i on 
	Indexing enabled. 
	Indexing enabled. 
/Volumes/New Ext INT DATA:
	Indexing and searching disabled.
tempscott@Temps-iMac New Ext INT DATA % 

So no result and as you can see from the error that I obviously do not understand terminal syntax and don’t know how to type that last command that is supposed to enable indexing and searching on “New Ext INT DATA”

(I DON’T KNOW WHAT THE RIGHT ARROW MEANS EXACTLY. I cut and pasted to get the above error and then tried just the sudo etc. (I also tried typing a tab for the right arrow which also failed. I don’t even know what he means by the word “Backups” in that last command either.)

Can you tell me what I’m doing wrong?

OK, well at least we know it’s not an issue with Hook.

Now please try this Rebuild the Spotlight index on your Mac - Apple Support. You don’t need to rebuild the entire index, just the folders on the external drive.

So drag and drop the external-drive folders that you want indexed into the Privacy pane, then remove said folders. Then wait for Spotlight to do its magic.

Once you know that Spotlight can find the files it needs, Hook should be able to resolve the links.

I tried hours ago dragging the external drive into and out of the Spotlight/Privacy System Preferences. I also tried just now dragging all of the individual folders on that drive into that Privacy pane and then deleting them again with the “-” button.

Nothing seems to be re-indexing. Like I said originally I used this method to rebuild the system drive’s Spotlight index successfully. But nothing will get Spotlight working on the external drive and according to the following link this problem is actually an older bug than Big Sur!

“I asked someone if this was a new problem that arrived with Big Sur, but apparently not, this is a bug that has been in the MAC OS a long time. and it’s only certain drives.”

So I’m stumped. Terminal commands don’t work on this external drive any more than using the Sys Prefs Spotlight GUI procedure you mentioned.

Note: EasyFind instantly finds all kinds of stuff I ask for on that drive and I am going to go through my list of broken Hook bookmarks with that program to see if the files are indeed on that drive or not, at least.

As far as getting Spotlight to index and search that External SSD I am thinking darker and darker thoughts.

Haven’t encountered the issue. My main Mac is on Big Sur and I have a lot of extra drives for testing and backup. However, that does not help your case. Will dig and return to you via PM or here.

You are amazing. Thanks!

When I encounter spotlight issues I use mdutil but differently from what you mentioned above.

I would try this: macos - External hard drive not indexed by Spolight on Mac OS X Mountain Lion - Ask Different.

to get your drive name, you can drag and drop the drive into the Terminal app. Delete everything after /Volumes/<yourDriveName>/

the reason for mdutil -E /Volumes/<your_disk_name>/ is to instruct macOS to start its indexing over again for that drive, in case there’s a lingering corrupt index.

To wrap this up. The issue was indeed that @mascotca’s drive was not indexed by Spotlight. The drive seems to be ignoring the mdutil incantations for indexing. This is apparently something that can happen, albeit quite rarely.

To put this in context: Spotlight is one of the major beneficial features of macOS, as noted by Howard Oakley (see resources below). Without Spotlight, searching is very tedious (e.g., with UNIX find). Several tools, like Hook and HoudahSpot rely on Spotlight. In Hook’s case Spotlight is a fallback amongst other indexing techniques used by Hook.

Howard Oakley’s website is a great set of resources for all kinds of Mac troubleshooting , such as:

For Hook to find the files that have been copied to a failing drive, moving the files back to somewhere Spotlight can index is the solution. Having said that, if Hook links are created and remain on a volume that is not indexed by Spotlight, users won’t notice anything. We update Hook indexing techniques from time to time and dealing with a Spotlight failure would be possible.

Having said that, whether or not one uses Hook on a given drive, for various purposes it is a good idea to rebuild the Spotlight index on a drive if one finds Spotlight failing on said drive.