Deep links to Skim in macOS Sonoma are not working(fixed, script version 285)

It’s been months since macOS 14 Sonoma was released, So I just decided to updated to macOS 14 Sonoma (developer Beta5). Everything about Hookmark seem working fine after the updating, BUT (creating) deep link to Skim doesn’t work anymore.

I did a little testing. Only creating hookmark is affected (can’t do deeplink nor link to pdf document), while I still can open the deeplinks created before and jump to the right position. In other word, whether I select the text or directly invoke Hookmark in Skim, it will always prompt “No linkable item found in Skim”.

Is there anyway I could perhaps modify the scripts and fix the problem ASAP? It’s the feature I use heavily every day, and wish I could fix it without going back to the previous macOS version.

Sorry about this issue.

Could you please try reinstalling Skim and see if it helps?

If it does not, try giving Hookmark “Full Disk Access” and see if it helps. For most people, this is not necessary. But some customers need do this.

Thank you

Thank you for your reply.
I tried reinstalling both Skim and Hookmark, and giving “Full Disk Access”, but it didn’t work out.

Thank you for the info.

We are able to reproduce the problem. Could you please update your script and see if it fixes the issue? The latest script version is 285.

Thank you

Problem solved, thank you very much for your quick fix!