Deep Links Don't Work in Nitro (PDF Pen Pro)

I purchased Nitro PDF Pen Pro & Hookmark specifically for deep-linking PDFs, but find that I can only create a link, and not a deep link. Clicking the link created from a selected section of the PDF opens up the PDF, but not to the link location. Is deep linking Nitro no longer supported? I see some past issues reported with this.

I’ve got Nitro set as my default OS PDF application.
OS = Monterey, 12.5.1
Hookmark v = 5.0 (5317)
Nitro: com.gonitro.NitroPDF.retail
Nitro v = 13.3.0

Example link: hook://file/Ni8hP05Hf?p=RHJvcGJveC9fIEtDUg==&n=Holiday%5FThe%20obstacle%20is%20the%20way%2Epdf

I do not have “Reveal hook… targets in the Finder” selected.


Sorry for the trouble.
Could you please
(1)Select some text in a pdf document,
(2)Run the following script in Script Editor and post the result here.

use framework "Foundation"

property NSMutableCharacterSet : a reference to current application's NSMutableCharacterSet

on urlEncode(input)
	tell current application's NSString to set rawUrl to stringWithString_(input)
	set charset to NSMutableCharacterSet's URLQueryAllowedCharacterSet's mutableCopy
	charset's removeCharactersInString:"?"
	set theEncodedURL to rawUrl's stringByAddingPercentEncodingWithAllowedCharacters:charset
	return theEncodedURL as Unicode text
end urlEncode

set theFormatter to current application's NSNumberFormatter's alloc()'s init()
theFormatter's setPositiveFormat:"0.##"

theFormatter's setRoundingMode:(current application's NSNumberFormatterRoundHalfDown)
#in case some users have local setting to ","
theFormatter's setDecimalSeparator:"."

tell application id "com.gonitro.NitroPDFPro.retail"
	set d to front document
	set fpath to path of d
	set t to title of info of d
	if t = "" or t is missing value then
		set t to name of d
	end if
	set p to selected page of d
	set pr to p as record
	set pn to «class seld» of pr
	set x to selectionX of p
	set y to selectionY of p
end tell

if x = 0 then
	get "[" & t & "](file://" & urlEncode(POSIX path of fpath) & ")"
	set x to (theFormatter's stringFromNumber:x)
	set y to (theFormatter's stringFromNumber:y)
	get "[" & t & " - " & pn & "](file://" & urlEncode(POSIX path of fpath) & "#p=" & pn & "&x=" & x & "&y=" & y & ")"
end if

Some customers resolved the issue by reinstalling Nitro PDF Pen Pro or giving Hookmark full disk access. You can give them a try.

Thank you

Here’s the result I got:
“[The obstacle is the way - - 20](file:///Users/russ/Dropbox/_%20KCR/Holiday_The%20obstacle%20is%20the%20way.pdf#p=20&x=72&y=561.5)”

I’ll try giving Hookmark full disk access and then reinstalling Nitro now…

No luck with a Nitro reinstall nor giving Hookmark full disk access. The link looks well-formatted to me, as far as I can tell (which isn’t very far).

I am not selected text that is highlighted or annotated in any way, either.

Thanks for all the help attempts!

The link for Script Editor is good.

Have you tried restarting the mac?

Could you please check if the script is modified? Make sure there is no * at the end of “Nitro PDF Pro retail”.

Also make sure only one copy of Nitro and one copy of Hookmark.

Sorry for all the trouble and thank you for your patience.

I really appreciate the prompt help here with this.

I’m not sure I understand your request. The resulting MD link from the script is good but you want me to make sure that there isn’t a problem with it–? There is no asterisk. But I had to modify the application id since on my system it is: “com.gonitro.NitroPDF.retail” (without the “Pro” even though the name of the app includes the work, “Pro”).

No luck with a restart either, unfortunately.

1 Like

Sorry I thought it is a PRO version. This version is not supported yet.

A fix is available on our script server now. Could you please go to Hookmark Preferences->Update to update the script? The version should be 259.

You might need restart Hookmark.

Please let us know if there is any problem.

Thank you

1 Like

There appears to be a few layers of confusion here (probably due to my lack of clarity).

  1. I paid for, downloaded, and installed an app called, “Nitro PDF Pro Essentials”, which I assume is Nitro Pro. The name of the app is Nitro PDF Pro Essentials. Yet, the application ID is: “com.gonitro.NitroPDF.retail”. I have reached out to them to ask about the discrepancy.

  2. You said that, “This version is not supported yet”. I assume you are referring to the non-pro version. Immediately after, you then says that “A fix is available on our script server now.” Which is it? I am running version 259 right now.

It’s starting to seem to me that if there are only 2 PDF apps that support deep links, and they are not reliable for a professional workflow (because of OS AppleScript changes that happen, or reluctant software partners) then perhaps it might be better to stick within Zotero where the deep links always work. But I’m open to the possibility of solving the current issue.


Sorry for the confusion. What the fix means here is that we added the support for “Nitro PDF Pro Essentials”, in script version 259. There are 5 different Nitro PDF apps. Somehow we missed this one.

Do you mean it is still not working?

Well, I was already on version 259, and I did not recently reboot, or re-load anything and it’s now working. I guess I won’t question it, but it would be nice to know why for the future. Thanks for all your help.

Did you have auto check for update on? You can find that out in Hookmark Preferences window → Update. Or did you manually check for update? Must be one of them, so Hookmark downloaded the latest script 259 which supports Nitro essential version. Version 259 script is only available on the server yesterday.