Deep link fails in Finder

Hello. I am a brand new user.

I find that hooking (using Copy Link or Make Hookmark File) to a piece o text in a PDF results in a link which opens the file.

I am expecting that the link will open the file and scroll/jump to that specific piece of text.

What have I missed?

All help appreciated.


Welcome to Hookmark forum, @jcarman .

May I ask which PDF app you are using?

Also could you please post a copy link result here?

Thank you

I am using Skim. I find it works intermittently. I would prefer Preview, which only seems to open the file. Thank you for the response.

How To Get macOS Betas: How To Install Monterey Bata | Macworld.pdf

Sorry Preview is not supported yet.

For Skim, in order to get a deep link, the text needs be selected. When it is not working, could you please check if the link is deep link, it should have the similar format as the link below:

Here is an example of a non-deep link:

Thank you

I wouldn’t know from your example. I do I attend to only the differences? What do they mean?

This link now points to the same text, as do all my links. Nothing is unique unless is simply opens the file: [Zenith](hook://file/TNGvxWDiD?p=RG9jdW1lbnRzL1BERnM=&n=Manyoshu%20The%20Complete%20Nippon%20Gakujutsu%20Shinkokai%20Translation%20%20%20%201965%2Epdf#p=36&x=0&y=0&s=975&e=980)

I find every time I make a link it takes the form of whatever is newest and so do older links which once went to unique texts when they are used either as hookmark files or bookmarks in the app become the same. In short, I have lots of links all linked to the same thing which once linked to different things.

The deep link looks good.

Some users experience this problem before.

Some of them solved this problem by reinstalling SKIM. Some of them solved the problem by giving Hookmark Full Disk Access. Could you please give them a try?

May I ask what’s your Hookmark version, script version(you can find it in Hookmark about window) and SKIM version? I assume you didn’t make any change to the script for SKIM in Hookmark preferences window, is this right?

Thank you

It seems disk access was the issue, possibly a file was in iCloud and not local, but after giving access things seem to work

For reasons I do not understand, Hookmark lost full disk access. I am sure I did not do this. I granted it again in Preferences. I suspect Ventura as it has been flaky with text input as of late. The cursor is not reliable, so possibly I did click it off unintentionally.

Certainly, disk access is why this problem happens, regardless.

I knew if I said I was sure, things would go awry. Deep linking still fails.:nerd_face:

Could you please try restarting the machine and see if it helps?

Thank you

I find a restart uncertain as to whether it helps. Afterwards, it jumps to the page, but not the location. Is this the expected behavior? Perhaps I do not understand what it should do.

The .pdf to which I am linking was made from an .rtf.

If you select text using Tools ->Text Tool, then it will jumps to the page and select the text;
If you select text using Tools ->Select Tool, then it will jumps to the location, but does not select the text.

Thank you