Cannot change the default keyboard shortcut for "Show Hookmark context window"


I’m using Hookmark version 6.0.1 (5788) (Scripts version 312) in Pro mode on a Mac Studio (M1 Max, 2022) AND on a MacBook Pro 13" (M2, 2022), both running macOS Ventura Version 13.6.3.

I have a problem with changing the keyboard shortcut for “Show Hookmark context window” - BUT ONLY ON THE MACBOOK PRO: I cannot type any other keyboard shortcut than the default one ^H

As you can see in the screenshot above:

  • the field for the keyboard shortcut is locked (slightly grey compared to the other ones)
  • I was able to change the keyboard shortcuts for “Copy Link” and “Hook to Copied Link”, so the problem seems to be specific only to the “Show Hookmark context window”-setting.

As mentioned above this occurs only on the MacBook Pro - on the Mac Studio I could customize this keyboard shortcut to something else than the default.

Do you have any ideas?



Same here on a MacBook Air M1 2020. I thought this was locked for everyone until I read your post saying you can change it on other computers.

I checked, and it’s greyed out on my M1 Mac Studio, running 17.3. Hookmark 6.0.1

Sorry for the confusion, @VladGhitulescu , @martinewski , @Chris .

“Show Hookmark context window” can be disabled, but can’t be edited.

The one below it, “Show Hookmark context window(additional shortcut)”, can be edited. You can use this one for your chosen shortcut.

Thank you

Huh, I thought I’d changed mine to CTL-H a year or two back. Or is that the default now?

It is by default, @Chris .

Here it is @martinewski & @bchend my shortcut on the Mac Studio:

However I cannot see this option on my MacBook Pro.

@bchend any ideas how could I change it on my Mac Studio only?

Got it now: The second option - “Show Hookmark context window (additional shortcut)” - is available and active on my MacBook Pro too.