Apple Notes not linkable

when I’m on Apple Notes I get the Not linkable item message.

I’ve tried on the note opened on a specific window, on the note while on the main window…but nothing.

I’ve given Hookmark full access to access to everything possible on my Mac:

  • Accessibility is checked
  • Automation: Note is checked

My Mac is updated to 14.1, Hookmark 6.0.1 5788 via SetApp, scripts 301.
On the Scripts section fo the Settings I can see the Note script.

How do I fix it?

Sorry about this issue, @IvanPsy .

What’s your system language?

If you go to Hookmark Preferences->Scripts->Notes, does “Reset to default” button enabled?

If you select a note in Notes, then copy the “Get Address” Script to /Applications/Utilities/Script Editor, click the run button, what do you get?

Thank you



Non è vero che la tecnologia non arriva in alcune zone del mondo.è…

"[Non è vero che la tecnologia non arriva in alcune zone del mondo.è…](notes://dt/1699021845)"

That is the right note, at least the words here are the first ones of the note.

Thank you for the info, @IvanPsy .

Could you give the following a try ?

Thank you

1.1 Your accessibility permission database is corrupted

The macOS accessibility permissions database can get confused. In that case you might see strange behavior like not being able to disable or enable permissions for an app. In that case, you may reset Accessibility for Hookmark as follows:

  1. tccutil reset Accessibility com.cogsciapps.hook
  2. Reboot your Mac.

I’ve tried to repair the permissions with Clean My Mac, hoping not to reboot the Mac.
Now it seems to work.
I follow up if something goes wrong next days.
Thank you for your advice.

Thank you for letting us know. I am glad it works