Any way to change title menu kb shortcut?

Is there any way to change the title menu keyboard shortcut to something other than ⌃T, which conflicts with something else on my system? Was hoping to find it in the prefs but nope.

There’s no way to change those keyboard shortcuts in Hook itself. So we’ll take that as a feature request.

Keyboard Maestro might do the job. Users here (or there) that are more familiar with it than I am might know the incantation.

For commands that are listed in Hook, you can use System Preferences to tailor keyboard shortcuts, of course.

1 Like

I played around with trying to get KM to recognize the menu icon, but I haven’t been able to get it to trigger without dismissing the Hook window. I might try including both invoking the Hook window and clicking the menu within the macro, but I think I’d have to either occupy an additional keyboard trigger, or set Hook to show the main window on clicking the menu bar icon and invoke it that way within the macro — which is starting to get even more kludgey than most of my KM macros…

What shortcut you want to change for the title menu? We might be able to run commands on Terminal to achieve this.

Right now, specifically the ⌃T to display the menu itself, but there are also conflicts with most of the other commands that use only the Control-key modifier.

1 Like

If you let us know the new shortcut you want to use for title menu, we can give you the terminal commands as a temp solution. Perhaps we can do the same thing for other shortcuts.

If I were free to set it to anything for my own use I’d probably use ⇧⌃↓ (shift-control-down arrow), or possibly ⇧⌃. (shift-control-period).

1 Like

(1)
The Terminal commands for ⇧⌃↓ (you need run two commands on Terminal)
defaults write com.cogsciapps.hook com.cogsciapps.mymeta.hot.key.open.link.title.menukeycode 125
defaults write com.cogsciapps.hook com.cogsciapps.mymeta.hot.key.open.link.title.menumodifier 10878976

(2)
The Terminal commands for shift-control-period:
defaults write com.cogsciapps.hook com.cogsciapps.mymeta.hot.key.open.link.title.menumodifier 393216
defaults write com.cogsciapps.hook com.cogsciapps.mymeta.hot.key.open.link.title.menukeycode 43

If later you decide to use Hook default shortcut, you can always delete them.

1 Like

Thanks but unfortunately neither one seems to be working. I’ve quit and relaunched Hook after entering the defaults commands but have not yet tried logging out and back in.

Quit and relaunch Hook is not necessary. If you run the following command, what’s the output?
defaults read com.cogsciapps.hook|grep title

Perhaps the key modifier value is different on your machine.

The read command returns:

"com.cogsciapps.mymeta.hot.key.open.link.title.menukeycode" = 43;
"com.cogsciapps.mymeta.hot.key.open.link.title.menumodifier" = 393216;

I normally use a custom keyboard layout. I’m also on the Monterey beta, and I think there was something in one of the WWDC sessions about Monterey changing the way keyboard shortcuts are handled with international layouts, so one of those factors probably accounts for the defaults commands not working.

Sorry, the Terminal commands for shift-control-period should be:
defaults write com.cogsciapps.hook com.cogsciapps.mymeta.hot.key.open.link.title.menumodifier 393216
defaults write com.cogsciapps.hook com.cogsciapps.mymeta.hot.key.open.link.title.menukeycode 47

I messed up “,” with “.”.

I tested on Monterey, Mojave and big Sur, they all seem to be working fine.

But I am not sure the custom keyboard layout will make any difference.

If you like, you can find out the key code and modifiers by going to Hook Preferences window ->Shortcuts and change global “copy link” shortcut to shift-control-period. If it is not enabled, you need enable it first. Do remember change the shortcut to the original one after the experiment. Otherwise global copy link shortcut and title menu shortcut might be the same and will have problem.

After you type shift-control-period in “copy link” shortcut editor, go to Terminal, run the following command:
defaults read com.cogsciapps.hook|grep copy

It will show something like this:
“com.cogsciapps.mymeta.hot.key.copy.linkkeycode” = 47;
“com.cogsciapps.mymeta.hot.key.copy.linkmodifier” = 393216;

If it is different on your machine, you can use its keycode and modifier value to set the shortcut for title menu.