Although ver 1.8 installed, ver 1.7 attempts to install each time I boot my Mac

Catalina 10.5.15

I successfully updated to hook 1.8 (3439), but each time I boot my computer, Hook 1.7 installs itself as a virtual drive and proceeds with autoinstall Hook 1.7

thank you

That is this Hook Installation Loop Issue - Discussion & Help - Hook Productivity Forum, which we intend to address in next release in manner noted there. Sorry for the inconvenience.

In sum, for now one can zip and then discard the old DMG to avoid this manifesting itself.

1 Like

thank you very much Luc

sorry but I can’t find the DMG file. Where would it be and what is its name? thank you

I can’t tell, but if Spotlight indexes all the places where you download files or move downloaded files, it should be able to find it. Try searching for “.dmg”.

You may need to rebuild your Spotlight index or use an alternative search engine like HoudahSpot. Launchers can often find things quickly; you could type “Hook productivity dmg” in a launcher.

1 Like

Before disturbing you with my question, I had deleted the Hook 1.7 install dmg file (my first reflex) and already tried re-indexing spotlight and searching with HoudahSpot which I usually use for my searches instead of Spotlight. I had searched my main drive and all backup drives.

I finally found the problem: the Hook install file was in the trash, which is why neither spotlight nor HoudahSpot found it, and incredibly it auto installed from the trash at each startup. I did not know this was even possible.

When I deleted the file from the trash, the problem was solved.

I thought that you would be interested to know about this in case, you have similar issues with other users.

1 Like