AEON TIMELINE works partially? (AEON encodes URLs)

Hooks to PDFS and other files work when copied into an Event’s LINKS section and then clicked on.

But Hooks to any Emails throw an error.

I thought Hooks either work or don’t depending on whether an app has automation capabilities etc. Is there something about Apple Mail that accounts for this partial functionality in AEON TIMELINE?

Welcome to the Hook Productivity Forum , @mascotca. Thanks for putting Aeon on our radar.
Have you tried pasting the Mail links in TextEdit or something and clicking on them from there to ensure they work?

could you send a screenshot as a PM (clicking on my name and then messaging) or on the forum if suitable?

One thing that’s special about hook’s email links is that the mail client is configured in Hook’s Favorite Apps preferences pane. But if they work elsewhere it should be fine everywhere that other URLs work.

Mr. Beaudoin:

First let me say that Hook is revolutionary for me. I am beyond grateful for its creation and future development.

In AEON if I use the “Open in Browser” Button after creating a link in the LINKS section of a Timeline Event it works for things like Hook Links to files, including Pages and Word and PDF docs and Audionote1 files, for example.

The Hook Apple Mail links work in NotePlan 2. They work in Text Edit.

Here is the text of the hook file I am copying and.pasting and is what I used successfully in the above apps including, as you asked, Textedit:


But this identical Apple Mail link Hook fails in AEON.

Here is the Error:

CleanShot 2020-08-27 at 22.58.19

This is not confined to this one particular Email, btw. It failed on another one as well.

I am new to AEON today and was surprised it worked at all not seeing it on your approved apps list.

I hope this helps and again THANK YOU for a truly great application.

We haven’t run that app yet. but “open in browser” does not sound like a promising command for app links (whether hook’s or other apps like OmniFocus or things.)

Another particularity of hook://email URL is that they can contain non alpha-numeric various characters. Given that Hook is serving the same URLs in other contexts, it sounded like the issue is with AEON. Suspecting that AEON might be tripping over some of these characters, in this case the %40 (which encodes @) , I had a look. And I found this: URL Encoding | Aeontimeline

which indeed says:

Hi, Aeon Timeline is doing its own URI encoding, so we need to receive unencoded links for them to work. Jess

so that is the issue. Aeon does not like URLs with escape symbols.

If they have some way around URL encoding now (that post of theirs is c. 2 years old) we might be able to leverage it in additional additional URL processing. Will have a look later. (Feel free to let us know if you find a clue).

But meanwhile:

  1. Can you put ticks around the links so they are interpreted as text, then you could at least copy/paste them? (or perhaps you can already copy paste them). i.e., paste them in Spotlight or LaunchBar. That would open them. (Hook later will likely have a “go to copied URL” command.)
  2. Do Hook contextual-window links not help?

NB: I’ve taken the liberty of adding precisions in the topic title to help people make sense of the issue at a glance.

CLARIFICATION: I have to sheepishly confess that I mis-described that AEON button as having an “Open in Browser” floating Tool Tip designation. It actually says “Open Document” when you hover over it.

BTW, that is from the Inspector window, which is visible when one is creating a new Event’s details.

I neglected to add previously that if the Display preferences have been set to show the LINKS sub-section of Timeline Events, clicking on an email link there also fails exactly the same way described previously.

When I click on links from the Timeline itself I do get your contextual “Open in Hook?” window. Which works for all the apps I mentioned originally but again not for an Apple Mail hook. The contextual window does contain the correct text of all the kinds of apps links I have created so far. Only the Apple Mail ones don’t pass through. They always get that same error.

Putting tick marks in front of the hook link changes it in AEON. After entering the change the hook link now includes a prefix file://’ and a suffix '. I was unable to do anything further with that.

HOWEVER, if I leave the hook link alone BUT I enter the AEON Link’s editor mode from within the Inspector window and then highlight the entire hook link from there (there is no way to highlight the links directly in the Timeline itself) I CAN THEN USE THE LAUNCHBAR SENT TO FUNCTION. Command Key + holding Spacebar brings up Launchbar with the correct text of the link. I then simply hit Enter and voila: my email shows up error free.

So that seems to be the best workaround for now. 5 or 6 extra clicks or keyboard commands but it does give me back access to my hooked Emails.

Thanks for the suggestions and the extra info about how AEON works. BTW, they have a function they call SYNC by which they mean AEON links that open documents that have been saved into Scrivener and/or Ulysses. I have no experience with that but I may be playing with Ulysses later, thanks to its availability via my Setapp subscription.


1 Like