Version 172 of Hook software integration is available, Supports Fantastical by Flexibits

During WWDC in June, Apple announced its commitment to automation on the Mac. Shortcuts is coming to macOS. And Apple said it will continue to support AppleScript and other forms of automation. This will likely lead many Mac app developers who had held off on automation work to add automation to their apps, and to improve the automation of their apps if they already have some. This of course is great news for Hook users :blush: .

We’re pleased to announce that Flexibits has added an AppleScript API to Fantastical that makes Fantastical linkable and that:

with Version 172 of Hook integration, you can copy links to Fantastical entries and hook them to anything that is also linkable.


Since this is not UI scripted, this works in all languages.

How to get the updated integration

Hook’s automatic software update (if enabled) automatically updates Hook’s integration scripts without you needing to relaunch Hook. Using Hook’s Check for App Updates and Update Scripts command also updates the scripts, without you needing to relaunch Hook.


Please consider sharing this with your network who might benefit from this software: Twitter etc.


Thanks to Michael Simmons @ Flexibits, and the Fantastical developers and customer support for engaging back and forth with us @ CogSci Apps regarding this integration.

Thanks also to the many Hook customers who expressed their desire for Fantastical to become a linkable app.

Related information

Some things you might want to link your calendar entries to:

1 Like

Hi, I have a question regarding this.
I tried to update to version 172 (the one that gives me the capabilities of using Hook with Fantastical), but my Hook Pro (currently installed: version 168) told me it’s the most recent.
Checked and realised upgrade license had lapsed in June, so I bought an update and installed it.
However, still no update, I remain stuck at version 168.
What can I do?

Solved my own problem. Checking updates from the Preferences / Update button installed version 172 of the scripts. Perhaps you look why that behaved differently from the Check for updates etc. option in the menubar of Hook?

are you using macOS 12 per chance?

Nope - 11.4. (This is just filler to achieve the required 20 characters)

1 Like

There are two causes of this situation (of not getting the updates) to our knowledge:

  1. User’s Updates license has expired
  2. The Updates command from the menubar icon does not update the script (we will fix that next) just the app.

This script isn’t working for me. I get a type error on line 7 (set theTitle).

Anyone else having this?

(SetApp version 3.4.1)

I think you mean Fantastical 3.4.1. That one was released July 2.

3.4.2 is the latest Fantastical

3.4.1 is the latest SetApp version of Fantastical — hopefully when they push 3.4.2 this will work.

I can’t find Fantastical on SetApp. Maybe it’s different in Canada.

we would need Fantastical’s SetApp bundle ID and a separate script. Users of course can duplicate our Fantastical script in Hook.

1 Like

:man_facepalming: You’re right. That would explain why it’s not updating when I tell SetApp to update!

I’ve manually updated and it works now. Much better integration!

Worth noting that 3.4.1 does support the AppleScript calls, but there must have been a bug on their end fixed in 3.4.2.

1 Like

I really want to try this feature, too, and am in the same boat. I’m on Hook 170. But when I update, it says I’m on Hook 3.1 - the latest available - and won’t update further. I’m doing “Check for App Updates and Update Scripts”

… Similar to abusch, above — I had exactly the same thing. If you update from the preferences tab, it does work. But if you do the usual update (via the cog); it doesn’t. I’m on latest Big Sur (M1 Mac).

1 Like

If you check in Hook > About , has your Updates license expired? In Hook 3.2 we have a bunch of improvements to deal with Updates license info.